Bug 1508903 - [abrt] [faf] gnome-shell: cogl_framebuffer_set_viewport(): /usr/bin/gnome-shell killed by 11
Summary: [abrt] [faf] gnome-shell: cogl_framebuffer_set_viewport(): /usr/bin/gnome-she...
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: mutter   
(Show other bugs)
Version: 7.5
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: rc
: ---
Assignee: Florian Müllner
QA Contact: Desktop QE
URL: http://faf.lab.eng.brq.redhat.com/faf...
Whiteboard:
Keywords:
: 1511806 1512528 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-02 13:26 UTC by Vladimir Benes
Modified: 2018-05-17 14:39 UTC (History)
7 users (show)

Fixed In Version: mutter-3.26.2-4.el7
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-04-10 13:06:05 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0770 None None None 2018-04-10 13:07 UTC

Description Vladimir Benes 2017-11-02 13:26:00 UTC
This bug has been created based on an anonymous crash report requested by the package maintainer.

Report URL: http://faf.lab.eng.brq.redhat.com/faf/reports/bthash/8bcc97ed25a82505feb177f5b2e6085780535f2e/

Comment 1 Vladimir Benes 2017-11-02 13:27:51 UTC
This occurs very often!!

Comment 3 Vladimir Benes 2017-11-08 14:54:13 UTC
It's coming from automated tests where we do always use screen recording, it's happening quite randomly. We use X with automated login. 
Use cases:
1. add an account via c-c and when the account is shown press esc and then ctrl+w to close c-c

I am not quite able to reproduce locally.

We have screencasting prolonged to 600 seconds to allow recording whole test.

Comment 4 Vladimir Benes 2017-11-08 14:54:59 UTC
Is anything visible from backtrace? Is there any more info I can provide?

Comment 5 Ray Strode [halfline] 2017-11-08 14:58:35 UTC
random stab in the dark guess:

--- a/clutter/clutter/clutter-stage.c
+++ b/clutter/clutter/clutter-stage.c
@@ -1489,4 +1489,5 @@ _clutter_stage_do_pick_on_view (ClutterStage     *stage,
-  cogl_set_viewport (priv->viewport[0] * fb_scale - viewport_offset_x,
-                     priv->viewport[1] * fb_scale - viewport_offset_y,
-                     priv->viewport[2] * fb_scale,
-                     priv->viewport[3] * fb_scale);
+  cogl_framebuffer_set_viewport (fb,
+                                 priv->viewport[0] * fb_scale - viewport_offset_x,
+                                 priv->viewport[1] * fb_scale - viewport_offset_y,
+                                 priv->viewport[2] * fb_scale,
+                                 priv->viewport[3] * fb_scale);


If i threw that in a scratch build, do you have some way to test the scratch build ?

Comment 7 Vladimir Benes 2017-11-10 08:48:23 UTC
*** Bug 1511806 has been marked as a duplicate of this bug. ***

Comment 10 Tomas Pelka 2017-11-13 14:19:01 UTC
*** Bug 1512528 has been marked as a duplicate of this bug. ***

Comment 12 Ray Strode [halfline] 2018-01-24 21:14:40 UTC
upstreamed here:

https://gitlab.gnome.org/GNOME/mutter/merge_requests/2

Comment 15 errata-xmlrpc 2018-04-10 13:06:05 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0770


Note You need to log in before you can comment on or make changes to this bug.