Bug 1508922 - There are a lot of "404 not found" errors in zaqar-server.log
Summary: There are a lot of "404 not found" errors in zaqar-server.log
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-zaqar
Version: 12.0 (Pike)
Hardware: Unspecified
OS: Unspecified
low
medium
Target Milestone: Upstream M2
: 13.0 (Queens)
Assignee: Thomas Hervé
QA Contact: Shai Revivo
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-02 14:01 UTC by Udi
Modified: 2018-06-27 13:39 UTC (History)
5 users (show)

Fixed In Version: openstack-zaqar-6.0.1-0.20180302005413.4659f9b.el7ost
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-27 13:39:00 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
OpenStack gerrit 517634 None master: MERGED zaqar: Reduce swiftclient logging (I01c84887a5ddcb76bb36f01fb8f52625decd7be1) 2018-03-29 16:11:19 UTC
Red Hat Product Errata RHEA-2018:2086 None None None 2018-06-27 13:39:48 UTC

Description Udi 2017-11-02 14:01:47 UTC
Description of problem:
This error is logged periodically (about once a minute) to zaqar-server.log:

INFO zaqar.transport.websocket.protocol [-] Response: API v2 txt, 201. Request: action "queue_create", body {"queue_name": "85fa5589-6fd3-40da-baf6-85dbbffb52a8"}.
INFO swiftclient [-] REQ: curl -i https://192.168.24.2:13808/v1/AUTH_3fa0d565e3c24ce580930f7381edcc33/zaqar_subscriber%3A85fa5589-6fd3-40da-baf6-85dbbffb52a8%3A809dfe94f8434c7d8da4d6fbd5d0c7ee/http%253A%252F%252Fundercloud-0.redhat.local%253A39847%252Fcf8b32d1-fec8-412a-bd6d-37c65f3764a7 -X PUT -H "if-none-match: *" -H "x-delete-after: 10000" -H "X-Auth-Token: gAAAAABZ-uQDpYLc..."
INFO swiftclient [-] RESP STATUS: 404 Not Found
INFO swiftclient [-] RESP HEADERS: {u'Date': u'Thu, 02 Nov 2017 09:23:15 GMT', u'Content-Length': u'70', u'Content-Type': u'text/html; charset=UTF-8', u'X-Openstack-Request-Id': u'txe8ab1cf141dc4e0a91ff4-0059fae403', u'X-Trans-Id': u'txe8ab1cf141dc4e0a91ff4-0059fae403'}
INFO swiftclient [-] RESP BODY: <html><h1>Not Found</h1><p>The resource could not be found.</p></html>


Version-Release number of selected component (if applicable):
openstack-zaqar-5.0.1-0.20170929082616.2d42d4d.el7ost.noarch
openstack-swift-object-2.15.2-0.20170927035729.0344d6e.el7ost.noarch


How reproducible:
100%


Steps to Reproduce:
1. Install the undercloud 
2. Look in /var/log/zaqar/zaqar-server.log


Actual results:
404 errors


Additional info:
This error might be harmless. No observable problems are known to be related to this issue. It just looks like something that shouldn't happen.

Comment 5 Udi 2018-04-18 05:45:02 UTC
Hi Thomas. The patch only reduces the logging level - what causes these 404s in the first place, and why is it ok to just not log them?

Comment 6 Thomas Hervé 2018-04-18 07:46:24 UTC
Zaqar needs to check object existence in Swift. 404 are returned when such objects don't exist. It's part of the normal lifecycle that those objects don't exist, there is nothing wrong in that case.

Comment 8 errata-xmlrpc 2018-06-27 13:39:00 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:2086


Note You need to log in before you can comment on or make changes to this bug.