Bug 1509030 - Live Storage Migration failed in VmReplicateDiskFinishVDSCommand due to block job not complete
Summary: Live Storage Migration failed in VmReplicateDiskFinishVDSCommand due to block...
Keywords:
Status: CLOSED DUPLICATE of bug 1312909
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 4.1.5
Hardware: Unspecified
OS: Linux
unspecified
high
Target Milestone: ovirt-4.3.0
: ---
Assignee: Benny Zlotnik
QA Contact: Elad
URL:
Whiteboard:
Depends On: 1312909
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-02 18:15 UTC by Gordon Watson
Modified: 2019-05-16 12:57 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-02-19 09:09:43 UTC
oVirt Team: Storage
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 3231051 None None None 2018-04-23 15:25:11 UTC

Description Gordon Watson 2017-11-02 18:15:09 UTC
Description of problem:

Live Storage Migration failed in VmReplicateDiskFinishVDSCommand, due to the block job not having completed. VmReplicateDiskFinishVDSCommand was issued a second time, it failed again for the same reason, although the block copy had progressed since the previous time, and then the LSM sequence terminated, and a Live Merge was then issued, which also failed, expectedly, as a block job was still active.

This left volumes in the target storage domain, and the active volumes were still mirrored, as the block copy had not been terminated.

Volume extension was still being executed on the host after the LSM had completed.


Version-Release number of selected component (if applicable):

RHV 4.1.5
RHV-H 4.0-7.1;
  vdsm-4.18.24-3.el7
  libvirt-2.0.0-10.el7_3.5 
  qemu-kvm-rhev-2.6.0-28.el7_3.6


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 15 Tal Nisan 2018-02-19 09:09:43 UTC

*** This bug has been marked as a duplicate of bug 1312909 ***

Comment 16 Elad 2018-08-02 08:13:48 UTC
DUP bug 1312909 has qe_test_coverage+ so set this one to -

Comment 17 Franta Kust 2019-05-16 12:55:13 UTC
BZ<2>Jira re-sync


Note You need to log in before you can comment on or make changes to this bug.