Bug 1509112 - [quick installer][3.7]wrong variant_version in installer.cfg.yml [NEEDINFO]
Summary: [quick installer][3.7]wrong variant_version in installer.cfg.yml
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.7.0
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ---
: 3.7.z
Assignee: Scott Dodson
QA Contact: Wenkai Shi
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-03 06:16 UTC by Wenkai Shi
Modified: 2017-11-29 15:32 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
The quick installer now supports installation of OCP 3.7.
Clone Of:
: 1544207 (view as bug list)
Environment:
Last Closed: 2017-11-29 15:32:55 UTC
Target Upstream Version:
erich: needinfo? (trankin)


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2017:3280 normal SHIPPED_LIVE OpenShift Container Platform atomic-openshift-utils bug fix 2017-11-29 20:32:42 UTC

Description Wenkai Shi 2017-11-03 06:16:33 UTC
Description of problem:
atomic-openshift-installer generate wrong variant_version in installer.cfg.yml.

Version-Release number of the following components:
atomic-openshift-utils-3.7.0-0.190.0.git.0.129e91a.el7

How reproducible:
100%

Steps to Reproduce:
1. Use quick installer.
# atomic-openshift-installer install
2. Check installer.cfg.yml.
# grep "3.6" .config/openshift/installer.cfg.yml
variant_version: '3.6'
3.

Actual results:
# grep "3.6" .config/openshift/installer.cfg.yml
variant_version: '3.6'

Expected results:
Should be 3.7

Additional info:
May some other variables need to fix:
# grep -nir "3.6" /usr/lib/python2.7/site-packages/ooinstall/
/usr/lib/python2.7/site-packages/ooinstall/cli_installer.py:37:        'major_playbook': 'v3_6/upgrade.yml',
/usr/lib/python2.7/site-packages/ooinstall/cli_installer.py:38:        'major_version': '3.6',
/usr/lib/python2.7/site-packages/ooinstall/cli_installer.py:40:    '3.6': {
/usr/lib/python2.7/site-packages/ooinstall/cli_installer.py:41:        'minor_version': '3.6',
/usr/lib/python2.7/site-packages/ooinstall/cli_installer.py:42:        'minor_playbook': 'v3_6/upgrade.yml',
/usr/lib/python2.7/site-packages/ooinstall/variants.py:42:    Version('3.6', 'openshift-enterprise'),
/usr/lib/python2.7/site-packages/ooinstall/variants.py:46:    Version('3.6', 'openshift-enterprise', 'registry'),
/usr/lib/python2.7/site-packages/ooinstall/variants.py:50:    Version('3.6', 'origin'),

Comment 1 Wenkai Shi 2017-11-03 07:28:11 UTC
Modify the variant_version to 3.7, met this:

# atomic-openshift-installer -u install 
openshift-enterprise 3.7 is not an installable variant.

# tail -3 .config/openshift/installer.cfg.yml
variant: openshift-enterprise
variant_version: '3.7'
version: v2

Comment 3 Scott Dodson 2017-11-27 20:04:15 UTC
https://github.com/openshift/openshift-ansible/pull/6274 adds v3.7 support to the quick installer

Comment 6 Wenkai Shi 2017-11-28 04:13:59 UTC
Verified with version openshift-ansible-3.7.9-1.git.35.36453c1.el7. The variant_version in installer.cfg.yml is 3.7 now. 

# tail -3 .config/openshift/installer.cfg.yml
variant: openshift-enterprise
variant_version: '3.7'
version: v2

Comment 10 errata-xmlrpc 2017-11-29 15:32:55 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:3280


Note You need to log in before you can comment on or make changes to this bug.