Bug 150915 - hal failing to initialise USB card reader
hal failing to initialise USB card reader
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: hal (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: David Zeuthen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-11 18:11 EST by Paul F. Johnson
Modified: 2013-03-05 22:42 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-12 16:15:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of running hald --daemon=no --verbose=yes --retain-privileges (1.40 KB, text/plain)
2005-03-11 18:11 EST, Paul F. Johnson
no flags Details
Output from ps aux | grep hald (75 bytes, text/plain)
2005-03-11 18:13 EST, Paul F. Johnson
no flags Details
Output from dmesg (25.74 KB, text/plain)
2005-03-11 18:14 EST, Paul F. Johnson
no flags Details
Output from hald when run as su - instead of just su (194.42 KB, text/plain)
2005-03-11 21:00 EST, Paul F. Johnson
no flags Details
lshal after performing the hald update in rawhide 12/03/05 (105.51 KB, text/plain)
2005-03-12 15:44 EST, Paul F. Johnson
no flags Details
Output from ps aux | grep hald after running the hald rawhide update (12/03/05) (498 bytes, text/plain)
2005-03-12 15:45 EST, Paul F. Johnson
no flags Details
Output from tree /sys (84.71 KB, text/plain)
2005-03-12 15:53 EST, Paul F. Johnson
no flags Details

  None (edit)
Description Paul F. Johnson 2005-03-11 18:11:32 EST
Description of problem:
My internal USB 7 port card reader is currently not being seen by hal. It makes
no difference to which kernel version is used

Version-Release number of selected component (if applicable):
0.5.0-3

How reproducible:
Always

Steps to Reproduce:
1. Install the latest updates
2.
3.
  
Actual results:
See attachments. The card reader is not seen

Expected results:
The card reader is seen and able to be used

Additional info:
Comment 1 Paul F. Johnson 2005-03-11 18:11:32 EST
Created attachment 111910 [details]
Output of running hald --daemon=no --verbose=yes --retain-privileges
Comment 2 Paul F. Johnson 2005-03-11 18:13:54 EST
Created attachment 111911 [details]
Output from ps aux | grep hald

This is the output after 111910 fails. When I double click on the computer
icon, only the generic names for any hal devices are show (such as cdrecorder,
cdrecorder1). If I run /etc/init.d/haldaemon start, the correct names show when
I double click on the computer icon
Comment 3 Paul F. Johnson 2005-03-11 18:14:40 EST
Created attachment 111912 [details]
Output from dmesg
Comment 4 David Zeuthen 2005-03-11 19:57:50 EST
Output from comment 1 looks like you're not doing it right. 

1. are you running 'hald --daemon=no --verbose=yes --retain-privileges' as root?
You need to either 'su -' or login as root to get the $PATH right; specifically,
/usr/sbin needs to be in $PATH.

2. what is the output of 'rpm -q hal'

3. what is the output of 'ls -l /usr/sbin/fstab-sync'

4. what is the output of 'chkconfig --list haldaemon'

Thanks
Comment 5 Paul F. Johnson 2005-03-11 21:00:14 EST
Created attachment 111917 [details]
Output from hald when run as su - instead of just su
Comment 6 Paul F. Johnson 2005-03-11 21:04:03 EST
hald run as su - is attachment 111917 [details]

rpm -q hal -> hal-0.5.0-3
ls -l /usr/sbin/fstab-sync 
-rwxr-xr-x 1 root root 23728 Mar 8 16:32 /usr/sbin/fstab-sync
chkconfig --list haldaemon
haldaemon 0:off 1:off 2:off 3:on 4:on 5:on 6:off

(originally, this was tested with 5:off. I have not reset the machine since
doing the original test (see the original hald id=111910 attachment) but have
reset 5 to be on)
Comment 7 David Zeuthen 2005-03-11 21:13:54 EST
That looks better, thanks. Please attach the output 'lshal' and 'tree /sys' as
well (the tree command is in the tree package you might need to install).
Comment 8 David Zeuthen 2005-03-11 21:24:22 EST
Also, now that 5:on, does this symptom 

> When I double click on the computer icon, only the generic names for any hal
> devices are show (such as cdrecorder, cdrecorder1).

go away when rebooting?
Comment 9 Paul F. Johnson 2005-03-12 05:01:26 EST
lshal just gives
lshal version 0.5.0
*** [DIE] lshal.c:dump_devices():73 : Couldn't obtain list of device

With 5:on, the device names given in Computer are correct.

One very odd thing I've found though is that the card I inserted into the card
reader is now locked on my camera, the pictures are intact, so I'm assuming that
either the card was mounted but not unmounted or something has gone funny!
Comment 10 David Zeuthen 2005-03-12 14:34:30 EST
> lshal just gives
> lshal version 0.5.0
> *** [DIE] lshal.c:dump_devices():73 : Couldn't obtain list of device

Try this again and also send me the output of 'ps aux|grep hald'
Comment 11 David Zeuthen 2005-03-12 14:36:06 EST
You also forgot to include the output of 'tree /sys', please include that. And
also the output of /var/log/messages. Please do this after a clean reboot (with
5:on in chkconfig for haldaemon).
Comment 12 Paul F. Johnson 2005-03-12 15:44:26 EST
Created attachment 111924 [details]
lshal after performing the hald update in rawhide 12/03/05
Comment 13 Paul F. Johnson 2005-03-12 15:45:49 EST
Created attachment 111925 [details]
Output from ps aux | grep hald after running the hald rawhide update (12/03/05)

rpm -q hal
hal-0.5.0.cvs20050310-1
Comment 14 Paul F. Johnson 2005-03-12 15:53:21 EST
Created attachment 111926 [details]
Output from tree /sys

Sorry about that, I needed to install tree!
Comment 15 David Zeuthen 2005-03-12 16:15:13 EST
OK, so it appears that hal is actually working fine for you which kind of
contradicts what you posted on fedora-devel-list

 https://www.redhat.com/archives/fedora-devel-list/2005-March/msg00816.html

There's still the issue of the usb-storage driver not working with your
hardware, but that is not a hal bug; that's rather a kernel bug. So I'm closing
this as NOTABUG.

Cheers,
David

Note You need to log in before you can comment on or make changes to this bug.