Bug 1509225 (CVE-2017-12184) - CVE-2017-12184 xorg-x11-server: unvalidated lengths in XINERAMA extension
Summary: CVE-2017-12184 xorg-x11-server: unvalidated lengths in XINERAMA extension
Keywords:
Status: CLOSED WONTFIX
Alias: CVE-2017-12184
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard:
Depends On: 1509258
Blocks: 1509263
TreeView+ depends on / blocked
 
Reported: 2017-11-03 11:08 UTC by Adam Mariš
Modified: 2019-09-29 14:24 UTC (History)
12 users (show)

Fixed In Version: xorg-x11-server 1.19.5
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-07 07:27:36 UTC


Attachments (Terms of Use)

Description Adam Mariš 2017-11-03 11:08:48 UTC
Missing length validation was found in XINERAMA extension.

Upstream patch:

https://cgit.freedesktop.org/xorg/xserver/commit/?id=cad5a1050b7184d828aef9c1dd151c3ab649d37e

Comment 1 Adam Mariš 2017-11-03 11:08:56 UTC
Acknowledgments:

Name: the Xorg project

Comment 2 Adam Mariš 2017-11-03 12:30:18 UTC
Created xorg-x11-server tracking bugs for this issue:

Affects: fedora-all [bug 1509258]


Note You need to log in before you can comment on or make changes to this bug.