Bug 1509261 - accountsservice segfaults when installing flatpak
accountsservice segfaults when installing flatpak
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: accountsservice (Show other bugs)
7.5
Unspecified Unspecified
urgent Severity high
: rc
: ---
Assigned To: Ray Strode [halfline]
Desktop QE
: Regression, ZStream
Depends On:
Blocks: 1509330
  Show dependency treegraph
 
Reported: 2017-11-03 08:31 EDT by Tomas Pelka
Modified: 2018-05-17 10:39 EDT (History)
1 user (show)

See Also:
Fixed In Version: accountsservice-0.6.45-4.el7
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
: 1509330 (view as bug list)
Environment:
Last Closed: 2018-04-10 09:06:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
FreeDesktop.org 103560 None None None 2017-11-03 10:23 EDT
Red Hat Product Errata RHBA-2018:0770 None None None 2018-04-10 09:07 EDT

  None (edit)
Description Tomas Pelka 2017-11-03 08:31:56 EDT
Description of problem:
accountsservice segfaults when installing flatpak as non-root user, gnome-shell respawn once, second attempt lead to session termination (gdm appears).

Version-Release number of selected component (if applicable):
accountsservice-0.6.45-3.el7
gnome-shell-3.26.1-2.el7

How reproducible:
100%

Steps to Reproduce:
1. flatpak install --from https://flathub.org/repo/appstream/org.gnome.Builder.flatpakref as regular user
2.
3.

Actual results:

Nov 03 13:25:48 placka accounts-daemon[2328]: g_dbus_interface_skeleton_unexport: assertion 'interface_->priv->connections != NULL' failed
Nov 03 13:25:57 placka kernel: gnome-shell[12554]: segfault at 0 ip 00007f199a8d2aa9 sp 00007fff46062450 error 4 in libaccountsservice.so.0.0.0[7f199a8a6000+41000]
Nov 03 13:25:57 placka abrt-hook-ccpp[14687]: Process 12554 (gnome-shell) of user 1000 killed by SIGSEGV - dumping core
Nov 03 13:25:58 placka abrt-hook-ccpp[14687]: Failed to create core_backtrace: dwfl_getthread_frames failed: No DWARF information found
Nov 03 13:25:58 placka gnome-session[12334]: gnome-session-binary[12334]: WARNING: Application 'org.gnome.Shell.desktop' killed by signal 11
Nov 03 13:25:58 placka gnome-session-binary[12334]: WARNING: Application 'org.gnome.Shell.desktop' killed by signal 11
Nov 03 13:25:58 placka polkitd[1040]: Unregistered Authentication Agent for unix-session:13 (system bus name :1.271, object path /org/freedesktop/PolicyKit1/AuthenticationAgent, locale en_US.UTF-8) (disconnected from bus)
Nov 03 13:25:58 placka polkitd[1040]: Operator of unix-session:13 FAILED to authenticate to gain authorization for action org.freedesktop.Flatpak.configure-remote for system-bus-name::1.347 [flatpak install --from https://flathub.org/repo/appstream/org.gnome.Builder.flatpakref] (owned by unix-user:tpelka)
Nov 03 13:25:58 placka abrt-server[14691]: Package 'gnome-shell' isn't signed with proper key
Nov 03 13:25:58 placka abrt-server[14691]: 'post-create' on '/var/spool/abrt/ccpp-2017-11-03-13:25:57-12554' exited with 1
Nov 03 13:25:58 placka abrt-server[14691]: Deleting problem directory '/var/spool/abrt/ccpp-2017-11-03-13:25:57-12554'
Nov 03 13:25:59 placka gnome-shell[14694]: Property 'Synaptics Capabilities' for device 'SynPS/2 Synaptics TouchPad' returned 7 items, expected 4
Nov 03 13:25:59 placka gnome-shell[14694]: JS WARNING: [resource:///org/gnome/shell/ui/main.js 315]: reference to undefined property "MetaStage"
Nov 03 13:25:59 placka gnome-shell[14694]: JS WARNING: [resource:///org/gnome/shell/ui/layout.js 221]: reference to undefined property "MetaWindowGroup"
Nov 03 13:25:59 placka gnome-shell[14694]: JS WARNING: [resource:///org/gnome/shell/ui/osdMonitorLabeler.js 59]: reference to undefined property "MetaDBusDisplayConfigSkeleton"
Nov 03 13:26:00 placka org.gnome.Shell.desktop[14694]: current session already has an ibus-daemon.
Nov 03 13:26:00 placka gnome-shell[14694]: JS WARNING: [resource:///org/gnome/shell/ui/slider.js 38]: reference to undefined property "CallyActor"
Nov 03 13:26:00 placka dbus[1074]: [system] Activating via systemd: service name='org.freedesktop.GeoClue2' unit='geoclue.service'
Nov 03 13:26:00 placka systemd[1]: Starting Location Lookup Service...
Nov 03 13:26:00 placka polkitd[1040]: Registered Authentication Agent for unix-session:13 (system bus name :1.348 [/usr/bin/gnome-shell], object path /org/freedesktop/PolicyKit1/AuthenticationAgent, locale en_US.UTF-8)
Nov 03 13:26:00 placka dbus[1074]: [system] Successfully activated service 'org.freedesktop.GeoClue2'
Nov 03 13:26:00 placka systemd[1]: Started Location Lookup Service.
Nov 03 13:26:00 placka gnome-shell[14694]: JS WARNING: [resource:///org/gnome/gjs/modules/tweener/tweener.js 540]: reference to undefined property "isSpecialProperty"
Nov 03 13:26:00 placka dbus[1074]: [system] Activating via systemd: service name='org.freedesktop.hostname1' unit='dbus-org.freedesktop.hostname1.service'
Nov 03 13:26:00 placka systemd[1]: Starting Hostname Service...
Nov 03 13:26:00 placka dbus[1074]: [system] Successfully activated service 'org.freedesktop.hostname1'
Nov 03 13:26:00 placka systemd[1]: Started Hostname Service.
Nov 03 13:26:01 placka org.gnome.Shell.desktop[14694]: Window manager warning: "XF86RFKill" is not a valid accelerator
Nov 03 13:26:02 placka gnome-shell[14694]: GNOME Shell started at Fri Nov 03 2017 13:26:00 GMT+0100 (CET)
Nov 03 13:26:02 placka gnome-shell[14694]: Allocating size to ShellEmbeddedWindow 0x237e2b0 without calling gtk_widget_get_preferred_width/height(). How does the code know the size to allocate?


Expected results:
no crash

Additional info:
Comment 1 Tomas Pelka 2017-11-03 08:48:15 EDT
I can reproduce the same by clicking shell's power button. Again that need auth and it failed.
Comment 9 errata-xmlrpc 2018-04-10 09:06:05 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0770

Note You need to log in before you can comment on or make changes to this bug.