Bug 1509334 - no brick device in graphite
Summary: no brick device in graphite
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: web-admin-tendrl-node-agent
Version: rhgs-3.3
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: Nishanth Thomas
QA Contact: Lubos Trilety
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-03 14:57 UTC by Lubos Trilety
Modified: 2017-12-18 04:39 UTC (History)
3 users (show)

Fixed In Version: tendrl-node-agent-1.5.4-2.el7rhgs
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-12-18 04:39:57 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2017:3478 normal SHIPPED_LIVE RHGS Web Administration packages 2017-12-18 09:34:49 UTC
Github Tendrl node-agent issues 666 None None None 2017-11-08 13:05:47 UTC
Red Hat Bugzilla 1507875 None None None Never

Internal Links: 1507875

Description Lubos Trilety 2017-11-03 14:57:04 UTC
Description of problem:
There's no device key in graphite under tendrl.clusters.$cluster_id.volumes.$volume_name.nodes.$host_name.bricks.$brick_path path. Because of this all 'Disk Load' panels on Grafana Tendrl-Gluster-Bricks dashboard says 'No data points'.

Version-Release number of selected component (if applicable):
tendrl-commons-1.5.3-1.el7rhgs.noarch
tendrl-gluster-integration-1.5.3-2.el7rhgs.noarch
tendrl-selinux-1.5.3-2.el7rhgs.noarch
tendrl-node-agent-1.5.3-3.el7rhgs.noarch
collectd-5.7.0-4.el7rhgs.x86_64
libcollectdclient-5.7.0-4.el7rhgs.x86_64
collectd-ping-5.7.0-4.el7rhgs.x86_64
tendrl-notifier-1.5.3-1.el7rhgs.noarch
tendrl-api-1.5.3-2.el7rhgs.noarch
tendrl-api-httpd-1.5.3-2.el7rhgs.noarch
tendrl-monitoring-integration-1.5.3-2.el7rhgs.noarch
tendrl-grafana-selinux-1.5.3-2.el7rhgs.noarch
tendrl-ansible-1.5.3-3.el7rhgs.noarch
tendrl-ui-1.5.3-2.el7rhgs.noarch
tendrl-grafana-plugins-1.5.3-2.el7rhgs.noarch

How reproducible:
100 %

Steps to Reproduce:
1. Prepare and install Gluster cluster, create some volume
2. Install Red Hat Gluster Storage Web Administration
3. Open Grafana and check 'Disk Load' panels on Tendrl-Gluster-Bricks dashboard

Actual results:
All panels prints 'No data points'.
There's no device in Graphite for any brick on any gluster node.

Expected results:
Panels should display correct information.
There should be some devices and related data present in Graphite.

Additional info:

Comment 1 Darshan 2017-11-08 06:34:25 UTC
I don't  see this issue in 1.5.4 release. Please reopen if this persists.

Comment 2 Darshan 2017-11-08 13:02:34 UTC
The issue persists with ssl enabled. Thanks Daniel for providing an instance with this issue.

Have posted a Fix. Moving The issue to POST.

Comment 3 Petr Penicka 2017-11-08 14:07:27 UTC
Triage Nov 8: Dev and QE agreed to have in 3.3.1 release.

Comment 6 Lubos Trilety 2017-11-14 12:10:12 UTC
Tested with:
tendrl-node-agent-1.5.4-2.el7rhgs.noarch

Disk load charts are populated.

Comment 8 errata-xmlrpc 2017-12-18 04:39:57 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2017:3478


Note You need to log in before you can comment on or make changes to this bug.