Bug 150947 - Kernel Panic - Not Syncing: fs/dcache.c
Summary: Kernel Panic - Not Syncing: fs/dcache.c
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: 3
Hardware: i686
OS: Linux
medium
high
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
: 160637 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-03-12 15:34 UTC by Kevin Fries
Modified: 2015-01-04 22:17 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-30 00:44:00 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Kevin Fries 2005-03-12 15:34:12 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050302 Firefox/1.0.1 Fedora/1.0.1-1.3.2

Description of problem:
Machine runs for a few days, then crashes (seemingly at random, but probably not) with this kernel panic.  Machine is pingable, but nothing is running.  All services stop!

Version-Release number of selected component (if applicable):
kernel-2.6.10-1.766_FC3

How reproducible:
Couldn't Reproduce

Steps to Reproduce:
1. unkown
2.
3.
  

Actual Results:  CRASH! BOOM!


Expected Results:  Stable Systems

Additional info:

[<c01788b0>] prune_dcache+0xcf/0x4d2
[<c01795dc>] shrink_dcache_memory+0x18/0x2f
[<c014a16d>] shrink_slab+0xf7/0x149
[<c014ba86>] balance_pgdat+0x1b2/0x2d9
[<c014bc66>] kswapd+0xb9/0xbb
[<c0133328>] autoremove_wake_function+0x0/0x2d
[<c0133328>] autoremove_wake_function+0x0/0x2d
[<c014bbad>] kswapd+0x0/0xbb
[<c01011dd>] kernel_thread_helper+0x5/0xb

Kernel panic - not syncing: fs/dcache.c:407: spin_is_locked
  on uninitialized spinlock d562cf0c

Comment 1 Dave Jones 2005-07-07 23:13:27 UTC
*** Bug 160637 has been marked as a duplicate of this bug. ***

Comment 2 Dave Jones 2005-07-15 20:01:59 UTC
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.

Comment 3 Christophe Lambert 2005-07-18 07:59:46 UTC
After the crashes at the beginning of june, I updated the kernel to the one of
Fedora 4 and the computer is running fine since then (+/- 1 month without a
single crash).

I will install the new Fedora 3 kernel to test it.

Best Regards
Christophe

Comment 4 Dave Jones 2005-07-30 00:44:00 UTC
As they are both based off of 2.6.12.1, I'm fairly confident this is fixed in
FC3 too. If it reoccurs, please reopen.



Note You need to log in before you can comment on or make changes to this bug.