Bug 1509805 - No PCIe BW and lane info show in the output of 'virsh nodedev-dumpxml'
Summary: No PCIe BW and lane info show in the output of 'virsh nodedev-dumpxml'
Keywords:
Status: CLOSED DUPLICATE of bug 1517372
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: libvirt
Version: 7.5
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: rc
: ---
Assignee: Erik Skultety
QA Contact: Jingjing Shao
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-06 06:44 UTC by yafu
Modified: 2017-11-27 08:47 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-27 08:46:12 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description yafu 2017-11-06 06:44:22 UTC
Description of problem:
No PCIe BW and lane info show in the output of 'virsh nodedev-dumpxml'
 
Version-Release number of selected component (if applicable):
libvirt-3.9.0-1.el7.x86_64
qemu-kvm-rhev-2.10.0-4.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1.Find a pcie device:
lspci -s 05:00.0 -v
05:00.0 Ethernet controller: Intel Corporation 82599ES 10-Gigabit SFI/SFP+ Network Connection (rev 01)
        Subsystem: Intel Corporation Ethernet Server Adapter X520-2
        Flags: bus master, fast devsel, latency 0, IRQ 79, NUMA node 0
        Memory at 91c80000 (64-bit, non-prefetchable) [size=512K]
        I/O ports at 2020 [size=32]
        Memory at 91f04000 (64-bit, non-prefetchable) [size=16K]
        Expansion ROM at 92180000 [disabled] [size=512K]
        Capabilities: [40] Power Management version 3
        Capabilities: [50] MSI: Enable- Count=1/1 Maskable+ 64bit+
        Capabilities: [70] MSI-X: Enable+ Count=64 Masked-
        Capabilities: [a0] Express Endpoint, MSI 00
        Capabilities: [e0] Vital Product Data
        Capabilities: [100] Advanced Error Reporting
        Capabilities: [140] Device Serial Number 90-e2-ba-ff-ff-11-d7-a4
        Capabilities: [150] Alternative Routing-ID Interpretation (ARI)
        Capabilities: [160] Single Root I/O Virtualization (SR-IOV)
        Kernel driver in use: ixgbe
        Kernel modules: ixgbe
 
2.#virsh nodedev-dumpxml pci_0000_05_00_0
<device>
  <name>pci_0000_05_00_0</name>
  <path>/sys/devices/pci0000:00/0000:00:02.2/0000:05:00.0</path>
  <parent>pci_0000_00_02_2</parent>
  <driver>
    <name>ixgbe</name>
  </driver>
  <capability type='pci'>
    <domain>0</domain>
    <bus>5</bus>
    <slot>0</slot>
    <function>0</function>
    <product id='0x10fb'>82599ES 10-Gigabit SFI/SFP+ Network Connection</product>
    <vendor id='0x8086'>Intel Corporation</vendor>
    <capability type='virt_functions' maxCount='63'/>
    <iommuGroup number='18'>
      <address domain='0x0000' bus='0x05' slot='0x00' function='0x0'/>
    </iommuGroup>
    <numa node='0'/>
  </capability>
</device>

Actual results:
No PCIe BW and lane info show in the output of 'virsh nodedev-dumpxml'

Expected results:
Should show the PCIe BW and lane info in the output of 'virsh nodedev-dumpxml' as follows:
<capabilitily>
...
<pci-express>
<link validity='cap' port='0' speed='5' width='4'/>
<link validity='sta' speed='5' width='4'/>
</pci-express>
</capabilitily>

Additional info:
can get the BW and lane info with libvirt-3.2.0-14.el7_4.1.x86_64.

Comment 2 Erik Skultety 2017-11-27 08:46:12 UTC

*** This bug has been marked as a duplicate of bug 1517372 ***


Note You need to log in before you can comment on or make changes to this bug.