Bug 1509853 - openshift_hosted_router_registryurl and openshift_hosted_registry_registryurl setting are not honored
Summary: openshift_hosted_router_registryurl and openshift_hosted_registry_registryurl...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.7.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 3.10.0
Assignee: Russell Teague
QA Contact: Johnny Liu
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-06 08:33 UTC by Johnny Liu
Modified: 2018-03-28 14:11 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
In rare cases the router or registry registryurl variables may need to be set to values other than the first master registry_url value. This change allows these variables to be set in the inventory (undocumented). openshift_hosted_router_registryurl openshift_hosted_registry_registryurl
Clone Of:
Environment:
Last Closed: 2018-03-28 14:11:22 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0489 None None None 2018-03-28 14:11:45 UTC

Comment 1 Scott Dodson 2017-11-06 13:36:53 UTC
I don't think this is a value that's likely to be set and we don't document it in the example inventories. Setting priority to low and target release 3.8.0

Comment 4 Russell Teague 2018-01-29 16:21:27 UTC
This PR [1] reworked the Hosted variables to avoid the issue of using 'set_fact' which prevented the ability to override variables in the inventory.  The fix is in 3.8 and 3.9.


[1] https://github.com/openshift/openshift-ansible/pull/6306

Comment 6 Johnny Liu 2018-01-31 09:46:50 UTC
Re-test this bug with openshift-ansible-3.9.0-0.34.0.git.0.c7d9585.el7.noarch, still reproduced.

There are still some task is overriding variables in the inventory

Installation log:
<--snip-->
PLAY [Create Hosted Resources - registry] **************************************

TASK [Gathering Facts] *********************************************************
Wednesday 31 January 2018  07:31:00 +0000 (0:00:09.600)       0:36:17.348 ***** 
ok: [aos-127.lab.sjc.redhat.com]

TASK [set_fact] ****************************************************************
Wednesday 31 January 2018  07:31:01 +0000 (0:00:01.333)       0:36:18.682 ***** 
ok: [aos-127.lab.sjc.redhat.com] => {"ansible_facts": {"openshift_hosted_registry_registryurl": "registry.reg-aws.openshift.com:443/openshift3/ose-${component}:${version}"}, "changed": false}

<--snip-->
PLAY [Create Hosted Resources - router] ****************************************

TASK [Gathering Facts] *********************************************************
Wednesday 31 January 2018  07:30:42 +0000 (0:00:00.037)       0:35:59.598 ***** 
ok: [aos-127.lab.sjc.redhat.com]

TASK [set_fact] ****************************************************************
Wednesday 31 January 2018  07:30:44 +0000 (0:00:01.376)       0:36:00.975 ***** 
ok: [aos-127.lab.sjc.redhat.com] => {"ansible_facts": {"openshift_hosted_router_registryurl": "registry.reg-aws.openshift.com:443/openshift3/ose-${component}:${version}"}, "changed": false}

Comment 7 Russell Teague 2018-02-16 13:52:15 UTC
Please provide a complete log and a copy of the inventory.

Comment 8 Russell Teague 2018-02-16 15:11:14 UTC
Proposed: https://github.com/openshift/openshift-ansible/pull/7181

Comment 9 openshift-github-bot 2018-02-17 04:15:48 UTC
Commits pushed to master at https://github.com/openshift/openshift-ansible

https://github.com/openshift/openshift-ansible/commit/685aa326afc8893e5ca2c414c333db7b03965312
Allow for overriding hosted registry_url variables

In rare cases the router or registry registryurl variables may need to
be set to values other than the first master registry_url value. This
change allows these variables to be set in the inventory (undocumented).

openshift_hosted_router_registryurl
openshift_hosted_registry_registryurl

Bug 1509853 | https://bugzilla.redhat.com/show_bug.cgi?id=1509853

https://github.com/openshift/openshift-ansible/commit/6a20c5e21228dc727d4287fb8b2206ae6bc984e3
Merge pull request #7181 from mtnbikenc/fix-1509853

Automatic merge from submit-queue.

[1509853] Allow for overriding hosted registry_url variables

In rare cases the router or registry registryurl variables may need to
be set to values other than the first master registry_url value. This
change allows these variables to be set in the inventory (undocumented).

openshift_hosted_router_registryurl
openshift_hosted_registry_registryurl

Bug 1509853 | https://bugzilla.redhat.com/show_bug.cgi?id=1509853

Comment 10 Russell Teague 2018-02-20 13:23:47 UTC
openshift-ansible-3.9.0-0.46.0

Comment 14 errata-xmlrpc 2018-03-28 14:11:22 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0489


Note You need to log in before you can comment on or make changes to this bug.