Bug 15099 - Xsetup_0 missing
Xsetup_0 missing
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
7.0
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Jeff Johnson
Winston gold
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-02 05:08 EDT by Gene Czarcinski
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-03 08:17:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gene Czarcinski 2000-08-02 05:08:56 EDT
I did an upgrade of a rhl 6.1 system to pinstripe.  Everything seemed to go
fine except that /etc/X11/xdm/Xsetup_0 was missing.  The previous Xsetup_0
was renamed to Xset_0.rpmsave but there was new "new" Xsetup_0.  The
original Xsession was renamed to Xsession.rpmsave and there was a new
Xsession.
Comment 1 Bill Nottingham 2000-08-02 19:26:18 EDT
That should be in the xinitrc package - do you have that
package installed?
Comment 2 Preston Brown 2000-08-04 10:16:27 EDT
jeff, this sounds like an rpm issue.
Comment 3 Glen Foster 2000-08-04 11:15:39 EDT
This defect is considered MUST-FIX for Winston Gold-release
Comment 4 Gene Czarcinski 2000-08-05 15:25:50 EDT
OK, I did more testing and this is a reproducable problem.

1. I did a TUI install of rhl 6.1 selecting gnome, kde, development, etc.

2. I booted the new system and edited /etc/X11/xdm/Xsetup_0 and
/etc/X11/xdm/Xsession to change the background color.

3. I then shutdown and did a TUI upgrade of the system with pinstripe.

4. When I rebooted the new system, both Xsession and Xsetup_0 had been renamed
*.rpmsave and there was a new Xsession file but NO Xsetup_0 file.

5. I checked and xinitrc was installed and the package listing showed it had a
/etc/X11/xdm/Xsetup_0 file.

Gene
Comment 5 Jeff Johnson 2000-08-06 19:11:06 EDT
Presumably the XFree86-3.3.5-17 packages are being referred to (or that there no
changes
to the marking of the file Xsetup_0).

In 6.1.3, the XFree86-3.3.5-17 spec file contains
	%config /etc/X11/xdm/Xsetup_0
and the file is included in the XFree86-3.3.5-17 base package.

Editing the file /etc/X11/xdm/Xsetup_0 changes the MD5 sum.

In pinstripe, the file has been moved to the xinitrc-2.9.7-1 and is marked
	%config(noreplace) /etc/X11/xdm/*

Because the file is modified (i.e. MD5 sum has changed), the removal (from
upgrading) of the
XFree86 package has a file resolution of backup (i.e. save copy of file with
extension .rpmsave).

The install of xinitrc has a file resolution of skip (if the file is modified)
or create (if the file is unmodified).

OK, given all the above, what would you like the behavior of rpm to be wrto the
disposition
of /etc/X11/xdm/Xsetup_0 when upgrading from Red Hat 6.1 to pinstripe?
Presumably,
you wish the existing contents to be left in place (i.e. removal of XFree86
should dispose
of file as skip, not backup) while the new contents should be saved with
extension .rpmnew
(i.e. install of xinitrc should dispose of file as altname).

There is no way to get this functionality into rpm-4.0, as the changes will be
at least as complicated
as the description above.



	
Comment 6 Jeff Johnson 2000-08-07 16:27:38 EDT
More information:

Upgrading from Red Hat 6.2 to pinstripe using rpm-4.0 and minimal necessary
transaction
set, the file disposition of a modified /etc/X11/xdm/Xsetup_0 is
	XFree86-* removal:	file is marked backup (i.e. rename with extension .rpmsave)
	xinitrc-* install		file is marked altname (i.e. new contents installed
with 						.rpmnew extension)

This is not perfect (read: the file should not have been renamed but rather left
in place) but
is exactly the behavior expected from rpm's %config handling as currently
implemented.

Note You need to log in before you can comment on or make changes to this bug.