Bug 150992 - Gettext isn't rebuildable using current Rawhide
Summary: Gettext isn't rebuildable using current Rawhide
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: gettext (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Leon Ho
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-03-13 17:44 UTC by Robert Scheck
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-21 11:10:35 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gettext-0.14.1-gcc4.patch (468 bytes, patch)
2005-03-13 17:44 UTC, Robert Scheck
no flags Details | Diff

Description Robert Scheck 2005-03-13 17:44:38 UTC
Description of problem:
Gettext isn't rebuildable using current Rawhide:

--- snipp ---
 gcc -c -DLOCALEDIR=\"/usr/share/locale\" -DLOCALE_ALIAS_PATH=\"/usr/share/locale\" -DLIBDIR=\"/usr/lib\" -DIN_LIBINTL -DENABLE_RELOCATABLE=1 -DIN_LIBRARY -DINSTALLDIR=\"/usr/lib\" -DNO_XMALLOC -Dset_relocation_prefix=libintl_set_relocation_prefix -Drelocate=libintl_relocate -DDEPENDS_ON_LIBICONV=1 -DHAVE_CONFIG_H -I. -I. -I.. -O2 -Wall -g -pipe -Wp,-D_FORTIFY_SOURCE=2 -m32 -march=i386 -mtune=pentium4 ./dcigettext.c  -fPIC -DPIC -o .libs/dcigettext.o
./dcigettext.c:154:15: error: macro "getcwd" requires 2 arguments, but only 1 given
./dcigettext.c:154: error: 'getcwd' redeclared as different kind of symbol
/usr/include/unistd.h:449: error: previous declaration of 'getcwd' was here
./dcigettext.c: In function 'libintl_dcigettext':
./dcigettext.c:544: error: called object 'getcwd' is not a function
make[3]: *** [dcigettext.lo] Error 1
--- snapp ---

Version-Release number of selected component (if applicable):
gettext-0.14.1-14
gcc-4.0.0-0.33
glibc-2.3.4-14

How reproducible:
Everytime, try to rebuild gettext.

Actual results:
Gettext isn't rebuildable using current Rawhide.

Expected results:
Gettext should be rebuildable.

Additional info:
The attached hack makes gettext currently rebuildable for me.

Comment 1 Robert Scheck 2005-03-13 17:44:39 UTC
Created attachment 111950 [details]
gettext-0.14.1-gcc4.patch

Comment 2 Robert Scheck 2005-03-21 11:10:35 UTC
Out of date, because of glibc-2.3.4-15:

- with -D_FORTIFY_SOURCE=*, avoid defining read and a bunch of others
  as function-like macros, there are too many broken programs
  out there

Closing now.


Note You need to log in before you can comment on or make changes to this bug.