Bug 151000 - Newest openoffice.org-libs depends on old db4 library
Newest openoffice.org-libs depends on old db4 library
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-13 14:09 EST by Jonathan Kamens
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-14 13:49:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Kamens 2005-03-13 14:09:06 EST
libdb_cxx-4.2.so is needed by
openoffice.org-libs-1.1.3-9.4.0.fc2.i386

I believe that dependency is provided by an old, obsolete db4 package
(I have db4-4.3.27-2 installed).
Comment 1 Dan Williams 2005-03-14 11:43:43 EST
AFAIK, the latest db4 package available for FC2 is:

db4-4.2.52-3.1

And since OOo depends on db4-4.2, this should be correct...

Have you installed a later version by yourself?
Comment 2 Jonathan Kamens 2005-03-14 11:48:55 EST
I'm not talking about FC2, I'm talking about FCdevel.  Here's what I have 
installed:

Name        : db4                          Relocations: (not relocatable)
Version     : 4.3.27                            Vendor: Red Hat, Inc.
Release     : 2                             Build Date: Fri 04 Mar 2005 
10:33:59 AM EST
Install Date: Mon 07 Mar 2005 09:27:12 AM EST      Build Host: 
porky.build.redhat.com
Group       : System Environment/Libraries   Source RPM: db4-4.3.27-2.src.rpm
Size        : 3801006                          License: GPL
Signature   : (none)
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
URL         : http://www.sleepycat.com/
Summary     : The Berkeley DB database library (version 4) for C.
Description :
The Berkeley Database (Berkeley DB) is a programmatic toolkit that
provides embedded database support for both traditional and
client/server applications. The Berkeley DB includes B+tree, Extended
Linear Hashing, Fixed and Variable-length record access methods,
transactions, locking, logging, shared memory caching, and database
recovery. The Berkeley DB supports C, C++, Java, and Perl APIs. It is
used by many applications, including Python and Perl, so this should
be installed on all systems.
Comment 3 Dan Williams 2005-03-14 12:50:06 EST
Well, the update appears to be looking for the FC2 version of OpenOffice.org
then, which is wrong, since Rawhide most definitely has a newer OOo than the RPM
you've listed here that causes the error...  Are you sure your yum repo files
are OK?

dcbw->cmc: when I tried to install 2.0 this weekend, the obsoletes and stuff in
the current OOo 2.0 packages in rawhide aren't correct and it would fail to
install.  We need to at least have openoffice.org-core obsolete "openoffice.org"
and "openoffice.org-libs".

Dan
Comment 4 Jonathan Kamens 2005-03-14 13:49:19 EST
You're right, I don't use yum, but my custom auto-download script downloaded 
old openoffice.org RPMs. Sorry for the false alarm.

Note You need to log in before you can comment on or make changes to this bug.