Bug 151001 - CDMA modem on USB does not respond under kernel 2.6.10-1.770_FC3
CDMA modem on USB does not respond under kernel 2.6.10-1.770_FC3
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-13 16:59 EST by Jim Wright
Modified: 2015-01-04 17:17 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-25 16:41:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Digest of /var/log/messages (8.91 KB, text/plain)
2005-03-13 17:01 EST, Jim Wright
no flags Details
Output of lsusb -v -s 0004:002 (3.21 KB, text/plain)
2005-04-03 03:43 EDT, Jim Wright
no flags Details

  None (edit)
Description Jim Wright 2005-03-13 16:59:09 EST
Description of problem:

I upgraded from 2.6.10-1.766_FC3 to 2.6.10-1.770_FC3 and 3 days later
could not use the internet. I found the modem no longer worked on
my wife's windoze  machine using supplier software either, so I got
returned it for repair and paid a deposit for a temporary replacement.

Then I found the replacement modem did not work on Fedora.
I rebooted and it still did not work. However it worked under windoze
so I tried  rebooting with kernel 2.6.10-1.766_FC3 and it works.

The possibility that might concern you is if the new kernel (with new
USB probing) is somehow damaging the modem, which would explain
why the old one did not work under windoze either but the new one
does. The guy in the shop claimed he'd confirmed a problem with the
old modem before sending it to be fixed. I've no idea if this is 
possible actually - most likely if the modem is badly designed.
IIRC it has Gtrans chips in it.

The possibility that concerns me is that its mainly a case of my
USB hub being on its last legs ;-)

Version-Release number of selected component (if applicable):

2.6.10-1.770_FC3

How reproducible:

Try and dial up or configure the interface to come up on booting.

Actual/Expecte results - I will attach a digest of /var/log/mesages 
with comments # LIKE THIS
Comment 1 Jim Wright 2005-03-13 17:01:14 EST
Created attachment 111955 [details]
Digest of /var/log/messages
Comment 2 Jim Wright 2005-03-19 15:44:30 EST
I've bought a new USB card and it has not changed anything. I guess other
hardware problems are a possibility e.g. something on the motherboard.

However, I came up against a situation where it would not work with either the
766 or 770 kernels and I fixed it by booting Red Hat 8.0 with kernel 2.4.18-14,
successfully using the modem and the rebooting with Fedora (and the 766 kernel).

It is possible that when the modem is switched on it does not work with Fedora
until it is first used with Red Hat 8.0 and kernel 2.4.18-14 or with Windoze.
The other possibility is that powering down the computer changes state in the
USB hardware but I don't think that explains the experiences I have had.

I will post again if I make progress but it all takes time and actually I posted
this bug because I was looking for an expert opinion, so I am not sure I should
bother ;-)
Comment 3 Jim Wright 2005-04-03 03:39:52 EDT
My original modem has now been returned and they found no problem (but
updated the firmware). So I think failure under windoze etc. was an illusion.

However comment #2 paragraph 3 appears true. Problem occurs with
2.6.10-1.766_FC3 and 2.6.10-1.770_FC3 kernels but not 2.4.18-14 (and RH 8.0)
or Windows XP and supplier drivers.
 
Note that since the modem is supposed to provide modile internet, it has a
rechargeable battery like a mobile phone and there is rarely a need to switch
it off.

I will attach standard output of lsusb -v. BTW it gave me this on stderr:

cannot peek string descriptor 3, error = Broken pipe(32)

Let me know if anyone wants anything else.
Comment 4 Jim Wright 2005-04-03 03:43:52 EDT
Created attachment 112634 [details]
Output of lsusb -v -s 0004:002 

stderr had: cannot peek string descriptor 3, error = Broken pipe(32)
Comment 5 Jim Wright 2005-04-25 16:41:12 EDT
This is fixed in 2.6.11-1.14_FC3 kernel. (Not sure whether resolution should be
CURRENTRELEASE or RAWHIDE in that case.)

Note You need to log in before you can comment on or make changes to this bug.