Bug 1510148 - system container install failed against an authenticated registry
Summary: system container install failed against an authenticated registry
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: skopeo
Version: 7.4
Hardware: Unspecified
OS: Unspecified
medium
high
Target Milestone: rc
: ---
Assignee: Giuseppe Scrivano
QA Contact: atomic-bugs@redhat.com
URL:
Whiteboard:
Depends On: 1505744
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-06 18:45 UTC by Scott Dodson
Modified: 2018-03-07 09:51 UTC (History)
15 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1505744
Environment:
Last Closed: 2018-03-07 09:51:12 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0429 normal SHIPPED_LIVE skopeo bug fix update 2018-03-07 14:52:05 UTC

Comment 3 Giuseppe Scrivano 2018-02-05 16:34:23 UTC
the fix is already in the latest Skopeo version.

Changing this to modified.

Comment 5 Alex Jia 2018-02-24 06:47:29 UTC
I can't reproduce this issue and it works well w/ atomic-1.21.1-1.git1170769.el7.x86_64 and skopeo-0.1.28-1.git0270e56.el7.x86_64 now.

[root@atomic-host-test-4109 cloud-user]# atomic host status
State: idle
Deployments:
● rhel-atomic-host-ostree:rhel-atomic-host/7/x86_64/standard
                   Version: 7.4.5 (2018-02-22 18:40:44)
                    Commit: e5bc41cb8a4c990382efc992e7dc96a609635edbad178e5a04589491eed97fee

[root@atomic-host-test-4109 cloud-user]# rpm -q atomic skopeo docker
atomic-1.21.1-1.git1170769.el7.x86_64
skopeo-0.1.28-1.git0270e56.el7.x86_64
docker-1.13.1-52.gitce62987.el7.x86_64

[root@atomic-host-test-4109 cloud-user]# atomic pull --storage ostree registry.reg-aws.openshift.com:443/openshift3/container-engine:v3.7
FATA[0003] Error determining manifest MIME type for docker://registry.reg-aws.openshift.com:443/openshift3/container-engine:v3.7: unauthorized: authentication required 

[root@atomic-host-test-4109 cloud-user]# atomic --debug pull --src-creds $user:$pwd --storage ostree registry.reg-aws.openshift.com:443/openshift3/container-engine:v3.7
Getting image source signatures
Copying blob sha256:9a32f102e6778e4b3c677f1f93fa121808006d3c9e002237677248de9acb9589
 71.40 MB / 71.40 MB [==================================================] 13m41s
Copying blob sha256:b8aa42cec17a56aea47fa45bd8029d1e877b21213017e849a839aadba9e1486c
 1.21 KB / 1.21 KB [========================================================] 0s
Copying blob sha256:ba5a7091468f338c44a808123be6837c0fa182b68654394b86553901fe5a58e6
 49.52 MB / 49.52 MB [===================================================] 1m52s
Copying config sha256:e357bf1ba9c3c4d72ceda0abb3c964c883f062c09c33e54c7ac2a4ecbf795640
 4.14 KB / 4.14 KB [========================================================] 0s
Writing manifest to image destination
Storing signatures

Comment 8 errata-xmlrpc 2018-03-07 09:51:12 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0429


Note You need to log in before you can comment on or make changes to this bug.