This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 151018 - authconfig doesn't process parameter --enablewinbindauth
authconfig doesn't process parameter --enablewinbindauth
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: authconfig (Show other bugs)
4.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tomas Mraz
Brian Brock
:
Depends On:
Blocks: 187538
  Show dependency treegraph
 
Reported: 2005-03-13 22:12 EST by Marc Olivier Chouinard
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version: RHBA-2006-0376
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-05-03 17:34:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marc Olivier Chouinard 2005-03-13 22:12:27 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.6) Gecko/20050225 Firefox/1.0.1

Description of problem:
Im trying to build a script to automate some masive deployment of box, but I got this little problem (I have to edit the file directly).  authconfig --enablewinbindauth doesn't work, it aint accepted (LDAP work fine and --enablewinbind work too, but not the enablewinbindauth (enableldap also do enableldapauth, should it be like that, if yes, should enablewinbind enable winbindauth also ?

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. authconfig --enablewinbindauth
2. Doesn't select the winbind authentification
3.
  

Actual Results:  Doesnt set the winbind authentification

Expected Results:  It should set the winbind authentification

Additional info:
Comment 1 Tomas Mraz 2005-03-14 03:27:47 EST
Yes this is a known bug. Could you please retest after the next update release.
Comment 2 Tomas Mraz 2005-03-14 03:52:52 EST
Wrong. It is not fixed in the packages for the next update release. I will fix
for the future updates of authconfig.

'enableldap also do enableldapauth, should it be like that,' I don't see this
behaviour here. And it shouldn't behave like this.
Comment 3 Marc Olivier Chouinard 2005-03-14 08:07:53 EST
ok maybe I was wrong for the enableldap, I've try it again latter.  Maybe once
you  there, you could add in the documentation that you can specify the password
for the join domain within the --winbindjoin=USERNAME%PASSWORD

Also shouldnt it have bring --joindomain= instead or something ? (since it a
winbind AND ads feature).

Also I really like this new version, it help in that I dont need to modify
everything.  The next thing to add is a ntpconfig, since timing is extremly
important when talking with an ADS domain, a simple ntpconfig utility to make it
update it time from the ads server could be very usefull. (if time is not sync
before the net join, net join hang then and WILL FAIL)

Oh and once your at it, would be great for you to add this in the authconfig :
session     required      /lib/security/$ISA/pam_mkhomedir.so skel=/etc/skel/
umask=0022

beable to configure that into the /etc/pam.d/system-auth, because if I do
manually, and call authconfig, it will remove that settings (and I find it very
usefull(EXCEPT that mkhomedir doesnt run as a high user level, so /home need to
be nearly world writable I think)

Also adding : obey pam restrictions = yes into the smb.conf AND session   
required     pam_mkhomedir.so skel=/etc/skel umask=0022 into /etc/pam.d/samba
make that when any user connect to my samba server, his home directory is
created automaticly.

Anyway these are just small idea that make this more complete.  Ive done a 120
line script that configure my system, but this authconfig upgrade from RHEL3 to
4 really reduced my code.  But having this, and maybe even if posible adding
simple stuff to automaticly make ldap + samba to work(at this point, nearly
everything is done), Im sure this would be a major feature to propagate (Btw,
this is a feature for NOW, not in the next 3 year release)
Comment 9 Marc Olivier Chouinard 2005-10-03 23:31:46 EDT
I guess Redhat doesn't fix bug faster than Microsoft.  You should have more
offen updates... it being 7+ months
Comment 12 Jay Turner 2005-10-21 11:05:47 EDT
Kicking back to proposed.  Package isn't on PM's content list.
Comment 13 Marc Olivier Chouinard 2005-10-22 21:52:14 EDT
Take your time, we have moved it back to a Windows 2003 box
Comment 14 Marc Olivier Chouinard 2005-10-22 21:54:37 EDT
(In reply to comment #13)
> Take your time, we have moved it back to a Windows 2003 box

This comment should have went to bug #157212
Comment 16 Tomas Mraz 2006-02-01 13:03:25 EST
RHEL4U4Proposed: Development work done long ago. There are other bugs in
authconfig accumulated.

Comment 22 Red Hat Bugzilla 2006-05-03 17:34:35 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2006-0376.html

Note You need to log in before you can comment on or make changes to this bug.