Bug 151029 - Slang isn't rebuildable against Rawhide
Summary: Slang isn't rebuildable against Rawhide
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: slang (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Petr Rockai
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-03-14 08:13 UTC by Robert Scheck
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-21 08:15:04 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
slang-1.4.9-gcc4.patch (1.08 KB, patch)
2005-03-14 08:13 UTC, Robert Scheck
no flags Details | Diff

Description Robert Scheck 2005-03-14 08:13:40 UTC
Description of problem:
Slang isn't currently rebuildable against Rawhide, this with multiple errors;
caused by gcc4 I would say.

Version-Release number of selected component (if applicable):
slang-1.4.9-16

How reproducible:
Everytime, try to rebuild slang.

Actual results / Expected results:
Slang should rebuild.

Additional info:
Attached patch makes it working for me.

Comment 1 Robert Scheck 2005-03-14 08:13:40 UTC
Created attachment 111964 [details]
slang-1.4.9-gcc4.patch

Comment 2 Petr Rockai 2005-03-21 08:14:44 UTC
Applied, rebuilt. Thanks for the patch. (Wondering how it managed to rebuild 
the last time, which should have been with gcc4 already... *shrug*). 

Comment 3 Robert Scheck 2005-03-21 08:32:18 UTC
My mistake - it wasn't gcc4 but the new glibc 2.3.4. Jakub changed glibc's 
behaviour again (?), see changelog from -16:

- with -D_FORTIFY_SOURCE=*, avoid defining read and a bunch of others
  as function-like macros, there are too many broken programs
  out there


Note You need to log in before you can comment on or make changes to this bug.