Bug 15104 - typo in kernel-source post install script
Summary: typo in kernel-source post install script
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
(Show other bugs)
Version: 7.0
Hardware: All Linux
medium
low
Target Milestone: ---
Assignee: Michael K. Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-08-02 11:09 UTC by bastiaan
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-04 20:23:33 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description bastiaan 2000-08-02 11:09:39 UTC
Syptoms:
Installing kernel-source-2.2.16-17.i386.rpm generates the following error
message:
D: running postinstall scripts (if any)
+ cd /usr/src
+ rm -f linux
+ ln -snf linux-2.2.16 linux
var/tmp/rpm-tmp.36107: line 15: syntax error: unexpected end of file
execution of kernel-source-2.2.16-17 script failed, exit status 2

Solution:
The postinstall script in the RPM contains the lines:
if [ 1 -eq 0 ] ; then
        cd /usr/include
        rm -f linux asm
        ln -snf ../src/linux/include/linux linux
        ln -snf ../src/linux/include/asm asm
endif

'endif' is incorrect, replace with 'fi'

Comment 1 Alan Cox 2000-08-02 15:52:11 UTC
One for the next build.


Comment 2 Michael K. Johnson 2000-08-04 20:23:31 UTC
FWIW, that was caused by a change from rpm %foo syntax to shell
syntax, and is fixed in all our current internal incremental
builds.  You will see this error again when the 2.2.16-17 packages
are uninstalled because they exist in the uninstall as well as
install scripts.

Comment 3 Alan Cox 2000-08-06 02:06:24 UTC
The -19 package seems just fine



Note You need to log in before you can comment on or make changes to this bug.