Bug 1510598 - libsmbclient smbc_statvfs_ctx returns f_bsize, f_blocks, and f_bfree as zero for Windows SMB2/SMB3 only shares
Summary: libsmbclient smbc_statvfs_ctx returns f_bsize, f_blocks, and f_bfree as zero ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: samba
Version: 7.4
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Andreas Schneider
QA Contact: Andrej Dzilský
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-07 19:00 UTC by aheverle
Modified: 2018-04-10 17:31 UTC (History)
6 users (show)

Fixed In Version: samba-4.7.1-2.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-10 17:30:15 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0937 None None None 2018-04-10 17:31:04 UTC
Samba Project 13138 None None None 2019-01-15 16:19:13 UTC

Description aheverle 2017-11-07 19:00:59 UTC
Description of problem:
When using the libsmbclient smbc_statvfs_ctx function call on a Windows 2016 or Windows 2012 R2 server that has the SMB1/CIFS features disabled through the server manager, the sizes are all returned as zero.



Version-Release number of selected component (if applicable):


How reproducible:
All the time. 

Steps to Reproduce:
You can easily repeat this using the teststatvfs example from the Samba code base. The attached log uses teststatvfs and then uses the smbclient command to show the difference. The smbclient command uses the Samba4 client code, where as libsmbclient uses Samba3 and other bridge code to make it work. It is a mess.

Actual results:
# ./teststatvfs
Path: smb://10.0.0.1/SHARE/
Workgroup: [WORKGROUP] 
Username: [root] <username>
Password: <password>
Workgroup: [WORKGROUP] 
Username: [root] <username>
Password: <password>

Block Size: 0
Fragment Size: 0
Blocks: 0
Free Blocks: 0
Available Blocks: 0
Files : 0
Free Files: 0
Available Files: 0

Flags: 0x40000000
Extended Features: NO_UNIXCIFS case_sensitive no_dfs 
Path: ^D



Expected results:
# smbclient //10.0.0.1/SHARE -U <username> -c du
Enter SAMBA\<username>'s password: <password>
Domain=[WIN-IV11090] OS=[] Server=[]

		65536000 blocks of size 4096. 57024222 blocks available
Total number of bytes: 0

Additional info:

Comment 2 Andreas Schneider 2017-11-14 15:38:49 UTC
If upstream will pick it up in time we can reconsider adding it to RHEL 7.5.

Comment 5 Andrej Dzilský 2018-02-05 09:28:47 UTC
Sanity Only here.

Comment 9 errata-xmlrpc 2018-04-10 17:30:15 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0937


Note You need to log in before you can comment on or make changes to this bug.