Bug 151066 - Reported non-increment of sourcepkgid by --rebuild
Reported non-increment of sourcepkgid by --rebuild
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-14 10:46 EST by R P Herrold
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-08 18:13:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description R P Herrold 2005-03-14 10:46:03 EST
Per channel maintenance request - mandrake reporter:

10:07  Nanar> jbj: rpmbuild --rebuild does not set this tag, for what I saw
10:09  jbj> which tag. %{arch} or %{cookie}? yah, %{cookie} used to trace back
            to original distro src.rpm, carried forward sneakily with
            --rebuild. from memory, %{cookie} has always been bizarre, do not
            rely on any behavior.
10:09  Nanar> %SUORCEPKGID
10:10  jbj> sourcepkgid not set with --rebuild is a bug (if true). bugzilla
            please.
10:10  Nanar> jbj: was on rpm 4.2, will check on 4.4
10:10  Nanar> so
10:10  jbj> sourcepkgid is in *.rpm, not *.src.rpm however.
10:11  Nanar> sure :)
10:11  jbj> it matches the header+payload md5 of the *.src.rpm.
Comment 1 Jeff Johnson 2005-03-19 15:32:34 EST
Confirmed, --rebuild does not set RPMTAG_SOURCEPKGID.
Comment 2 Jeff Johnson 2005-03-19 15:45:19 EST
And the reason is (drum roll please ;-) because no *.src.rpm
is produced by --rebuild! It's not really clear whether the
original sourcpkgid should be carried forward imho, as there
are still *.src.rpm packages that do not contain RPMTAG_SOURCEPKGID
around, so retrofitting a calculation of the src.rpm pkid
would be needed as well to guarantee sourcepkid exists in
all cases.
Comment 3 R P Herrold 2007-01-08 18:13:12 EST
closed per the fedora marching orders

> Now that Fedora legacy has dropped 3 and 4, it seems time to close the
> old bug reports regarding FC 3 and FC 4.
>
> We invite all maintainers to have a look at open tickets for those old
> releases and take appropriate actions as they see fit: move to newer
> releases or close down.

seems a waste, but there you go

Note You need to log in before you can comment on or make changes to this bug.