Bug 151090 - mozilla.spec file should not use hardcoded "mozilla" in paths
mozilla.spec file should not use hardcoded "mozilla" in paths
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: mozilla (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-14 14:50 EST by Mostafa Hosseini
Modified: 2008-02-03 19:40 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-03 19:40:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mostafa Hosseini 2005-03-14 14:50:17 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5) Gecko/20041217

Description of problem:
We recompile mozilla's rpm for our product under another name. Since we need our rpm to install on FC machines we need to change the paths so it doesn't conflict with the existing mozilla rpm.Each time a new version is out we have to go through the whole specfile and change the mozilla-%{version} entries to %{name}-%{version} . It would be good to have that change in the spec file by default, as it looks to be a more standard way of doing it too.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Look at mozilla.spec
2.Search for mozilla-%{version}
The occurences should be replaced by %{name}-%{version}

Additional info:
Comment 1 Matthias Clasen 2008-02-03 19:40:00 EST
I don't think this is relevant anymore, since we don't ship a mozilla package
anymore. A patch might have helped...

Note You need to log in before you can comment on or make changes to this bug.