Bug 151093 - gnome-cd is only barely functional
Summary: gnome-cd is only barely functional
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-media (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: John (J5) Palmieri
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: FC4Blocker
TreeView+ depends on / blocked
 
Reported: 2005-03-14 20:20 UTC by Bill Nottingham
Modified: 2014-03-17 02:52 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-22 20:44:10 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Bill Nottingham 2005-03-14 20:20:00 UTC
gnome-media-2.9.90-1

1) CDDB lookup doesn't work

** (gnome-cd:23632): WARNING **: Could not contact CDDB server

is printed at startup.

2) Hangs at the end of the CD:

(gdb) bt
#0  0x0042d7e2 in _dl_sysinfo_int80 () from /lib/ld-linux.so.2
#1  0x0068ed4e in __lll_mutex_lock_wait () from /lib/tls/libpthread.so.0
#2  0x0068bb45 in _L_mutex_lock_36 () from /lib/tls/libpthread.so.0
#3  0x04bc1fcf in ?? () from /usr/lib/libgstreamer-0.8.so.1
#4  0x04c69354 in ?? () from /usr/lib/libgstreamer-0.8.so.1
#5  0x00000001 in ?? ()
#6  0x00000001 in ?? ()
#7  0xbfe01618 in ?? ()
#8  0x04b9e177 in gst_thread_get_current () from
/usr/lib/libgstreamer-0.8.so.1
#9  0x04b9e177 in gst_thread_get_current () from
/usr/lib/libgstreamer-0.8.so.1
#10 0x04b76b06 in gst_element_wait_state_change ()
   from /usr/lib/libgstreamer-0.8.so.1
#11 0x04b69672 in gst_bin_set_state () from /usr/lib/libgstreamer-0.8.so.1
#12 0x04b76187 in gst_element_set_state () from
/usr/lib/libgstreamer-0.8.so.1
#13 0x080597a1 in gst_cdparanoia_cdrom_play (cdrom=0x940d4c0,
start_track=1,
    start=0xbfe01780, finish_track=-1, finish=0x0, error=0x0)
    at gst-cdparanoia-cdrom.c:877
#14 0x08053090 in play_cb (button=0x94854f0, gcd=0x940d658) at
callbacks.c:222
#15 0x0072c6e7 in g_cclosure_marshal_VOID__VOID ()
   from /usr/lib/libgobject-2.0.so.0
#16 0x00721162 in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#17 0x007309ab in g_signal_connect_closure_by_id ()
   from /usr/lib/libgobject-2.0.so.0
---Type <return> to continue, or q <return> to quit---
#18 0x007320f7 in g_signal_emit_valist () from
/usr/lib/libgobject-2.0.so.0
#19 0x0073246b in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#20 0x009da9bc in gtk_button_clicked () from /usr/lib/libgtk-x11-2.0.so.0
#21 0x009dc141 in gtk_button_get_alignment () from
/usr/lib/libgtk-x11-2.0.so.0
#22 0x0072c6e7 in g_cclosure_marshal_VOID__VOID ()
   from /usr/lib/libgobject-2.0.so.0
#23 0x00720c76 in g_cclosure_new_swap () from /usr/lib/libgobject-2.0.so.0
#24 0x00721162 in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#25 0x00730600 in g_signal_connect_closure_by_id ()
   from /usr/lib/libgobject-2.0.so.0
#26 0x007320f7 in g_signal_emit_valist () from
/usr/lib/libgobject-2.0.so.0
#27 0x0073246b in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#28 0x009da938 in gtk_button_released () from /usr/lib/libgtk-x11-2.0.so.0
#29 0x009db834 in gtk_button_set_relief () from
/usr/lib/libgtk-x11-2.0.so.0
#30 0x00a93e72 in gtk_marshal_VOID__UINT_STRING ()
   from /usr/lib/libgtk-x11-2.0.so.0
#31 0x00720c76 in g_cclosure_new_swap () from /usr/lib/libgobject-2.0.so.0
#32 0x00721162 in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#33 0x00730b37 in g_signal_connect_closure_by_id ()
   from /usr/lib/libgobject-2.0.so.0
#34 0x00731e6b in g_signal_emit_valist () from
/usr/lib/libgobject-2.0.so.0
#35 0x0073246b in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#36 0x00b6f7e3 in gtk_widget_activate () from /usr/lib/libgtk-x11-2.0.so.0
---Type <return> to continue, or q <return> to quit---
#37 0x00a925d7 in gtk_propagate_event () from /usr/lib/libgtk-x11-2.0.so.0
#38 0x00a92a14 in gtk_main_do_event () from /usr/lib/libgtk-x11-2.0.so.0
#39 0x00171ce4 in gdk_screen_get_setting () from
/usr/lib/libgdk-x11-2.0.so.0
#40 0x006bc43e in g_main_context_dispatch () from
/usr/lib/libglib-2.0.so.0
#41 0x006bf446 in g_main_context_check () from /usr/lib/libglib-2.0.so.0
#42 0x006bf733 in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#43 0x046d1625 in bonobo_main () from /usr/lib/libbonobo-2.so.0
#44 0x08052bbb in main (argc=6897652, argv=0x0) at gnome-cd.c:966
(gdb) info threads
* 1 Thread -1209013792 (LWP 23709)  0x0042d7e2 in _dl_sysinfo_int80 ()
   from /lib/ld-linux.so.2
(gdb)

Comment 1 Bill Nottingham 2005-03-16 17:53:27 UTC
2.10.0 didn't fix either of these.

Comment 2 John (J5) Palmieri 2005-05-09 19:53:23 UTC
CDDB looks fixed

Still a hang at the end of the cd

Comment 5 John (J5) Palmieri 2005-05-18 21:55:26 UTC
I backported gnome-cd to the 2.8 version (the one in FC3) manually and the hang
went away.  I'm going to diff the two to see what changed but if I can't figure
it out I'm just going to package the backport.  As for the CDDB stuff even Dan
is stumped on this one (Bug #157132).  It does seem to be SE-Linux but no error
messages are being spewed.

Comment 6 Bill Nottingham 2005-05-18 21:58:34 UTC
cddb doesn't work for me, and I'm not running SELinux.

Comment 7 John (J5) Palmieri 2005-05-19 18:46:14 UTC
I just built gnome-media-2.10.2-3 into head.  See if that fixes the hang
problem.  Also check out your /apps/CDDB-Slave2 gconf keys and tell me what
server and port are listed.

Comment 8 Bill Nottingham 2005-05-19 18:59:44 UTC
cddb appears to work now. Still hangs at end-of-cd, though.

Comment 9 John (J5) Palmieri 2005-05-20 23:07:44 UTC
fix is in fc4-HEAD as gnome-media-2.10.2-4.  Please test.

Comment 10 Bill Nottingham 2005-05-21 00:55:45 UTC
Works for me.


Note You need to log in before you can comment on or make changes to this bug.