This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 151107 - nfs client should try both udp and tcp protocols
nfs client should try both udp and tcp protocols
Status: CLOSED DUPLICATE of bug 150775
Product: Fedora
Classification: Fedora
Component: nfs-utils (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Steve Dickson
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-14 17:46 EST by Thomas Fitzsimmons
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-24 05:58:17 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Thomas Fitzsimmons 2005-03-14 17:46:11 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050308 Firefox/1.0.1 Fedora/1.0.1-5

Description of problem:
"mount -a" failed when I tried to mount an NFS mount from an AS2.1 server.  Someone told me that the default protocol has changed from udp to tcp.  The old server only accepts udp connections, so I was getting a failure message that the server was down.  Adding "udp" to the mount options made things work, but shouldn't that be automatic?  In otherwords, the new client should try tcp first and then fall back to udp, the old default.


Version-Release number of selected component (if applicable):
nfs-utils-1.0.7-1

How reproducible:
Always

Steps to Reproduce:
1. attempt to mount an NFS mount from an AS2.1 server


Actual Results:  Got "server down" message.


Expected Results:  Mount should have succeeded.


Additional info:

The workaround is to add udp to the mount options.
Comment 1 Joe Orton 2005-03-24 05:58:17 EST

*** This bug has been marked as a duplicate of 150775 ***

Note You need to log in before you can comment on or make changes to this bug.