Bug 1511094 - [TestOnly][RFE] Metadata reads/writes should not block on storage issues
Summary: [TestOnly][RFE] Metadata reads/writes should not block on storage issues
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-hosted-engine-ha
Classification: oVirt
Component: Broker
Version: 2.2.0
Hardware: Unspecified
OS: Unspecified
high
high vote
Target Milestone: ovirt-4.2.0
: ---
Assignee: Denis Chaplygin
QA Contact: Nikolai Sednev
URL:
Whiteboard:
Depends On: 1512534 1525907
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-08 16:32 UTC by Denis Chaplygin
Modified: 2017-12-20 10:46 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2017-12-20 10:46:54 UTC
oVirt Team: SLA
rule-engine: ovirt-4.2?
rule-engine: planning_ack?
rule-engine: devel_ack+
mavital: testing_ack+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 83306 None None None 2017-11-08 16:35:58 UTC
oVirt gerrit 83307 None None None 2017-11-08 16:36:50 UTC
oVirt gerrit 83308 None None None 2017-11-08 16:37:08 UTC
oVirt gerrit 83309 None None None 2017-11-08 16:37:25 UTC
oVirt gerrit 83310 None None None 2017-11-08 16:37:45 UTC
oVirt gerrit 83311 None None None 2017-11-08 16:38:00 UTC
oVirt gerrit 83312 None None None 2017-11-08 16:38:15 UTC
oVirt gerrit 83313 None None None 2017-11-08 16:38:29 UTC
oVirt gerrit 83314 None None None 2017-11-08 16:38:44 UTC
oVirt gerrit 83315 None None None 2017-11-08 16:39:00 UTC
oVirt gerrit 83316 None None None 2017-11-08 16:39:15 UTC

Description Denis Chaplygin 2017-11-08 16:32:16 UTC
https://www.ovirt.org/develop/release-management/features/sla/hosted-engine-agent-offloading/


That feature involved refactoring of hosted engine and huge change in a internal architecture. 

Those changes needs to be verified with ALL supported storage types.

Comment 1 Doron Fediuck 2017-11-13 10:21:35 UTC
Can we get a regression testing of all 4 storage types?

Comment 2 meital avital 2017-11-22 13:43:31 UTC
(In reply to Doron Fediuck from comment #1)
> Can we get a regression testing of all 4 storage types?

Yes

Comment 3 Nikolai Sednev 2017-11-22 14:06:12 UTC
Please provide reproduction steps for this bug.

Comment 4 Denis Chaplygin 2017-11-22 14:14:51 UTC
As this bug is a TestOnly for refactoring, there is no reproduction steps.

Actually you need to verify, that HE still works on all 4 types of storages.

Comment 8 Nikolai Sednev 2017-11-27 16:47:37 UTC
(In reply to Denis Chaplygin from comment #4)
> As this bug is a TestOnly for refactoring, there is no reproduction steps.
> 
> Actually you need to verify, that HE still works on all 4 types of storages.

https://bugzilla.redhat.com/show_bug.cgi?id=1517881 is blocking all types of deployments at this moment. I've tried for NFS, Gluster and iSCSI and met with failure.

Comment 9 Nikolai Sednev 2017-12-10 13:23:26 UTC
Deployed on RHEL7.4 hosts, using:
ovirt-hosted-engine-ha-2.2.0-0.0.master.20171128125909.20171128125907.gitfa5daa6.el7.centos.noarch
ovirt-hosted-engine-setup-2.2.0-0.0.master.20171129192644.git440040c.el7.centos.noarch
ovirt-engine-appliance-4.2-20171129.1.el7.centos.noarch

Over Gluster - passed; 
Over NFS - passed; 
Over iSCSI - passed; 
Over FC - TBD.

Comment 10 Nikolai Sednev 2017-12-18 13:40:12 UTC
SHE deployment over FC has failed. More details available from here: https://bugzilla.redhat.com/show_bug.cgi?id=1525907#c14.

Comment 11 Nikolai Sednev 2017-12-19 17:23:04 UTC
New deployment over FC was successful on these components:
rhvm-appliance-4.2-20171207.0.el7.noarch
ovirt-imageio-daemon-1.2.0-0.el7ev.noarch
ovirt-imageio-common-1.2.0-0.el7ev.noarch
ovirt-engine-sdk-python-3.6.9.1-1.el7ev.noarch
qemu-kvm-rhev-2.9.0-16.el7_4.13.x86_64
ovirt-setup-lib-1.1.4-1.el7ev.noarch
ovirt-host-4.2.0-1.el7ev.x86_64
ovirt-vmconsole-1.0.4-1.el7ev.noarch
mom-0.5.11-1.el7ev.noarch
vdsm-4.20.9.3-1.el7ev.x86_64
ovirt-host-dependencies-4.2.0-1.el7ev.x86_64
ovirt-hosted-engine-setup-2.2.2-1.el7ev.noarch
ovirt-vmconsole-host-1.0.4-1.el7ev.noarch
sanlock-3.5.0-1.el7.x86_64
ovirt-host-deploy-1.7.0-1.el7ev.noarch
ovirt-provider-ovn-driver-1.2.2-1.el7ev.noarch
libvirt-client-3.2.0-14.el7_4.5.x86_64
ovirt-hosted-engine-ha-2.2.2-1.el7ev.noarch
Linux version 3.10.0-693.15.1.el7.x86_64 (mockbuild@x86-019.build.eng.bos.redhat.com) (gcc version 4.8.5 20150623 (Red Hat 4.8.5-16) (GCC) ) #1 SMP Thu Dec 14 05:13:32 EST 2017
Linux purple-vds1.qa.lab.tlv.redhat.com 3.10.0-693.15.1.el7.x86_64 #1 SMP Thu Dec 14 05:13:32 EST 2017 x86_64 x86_64 x86_64 GNU/Linux
Red Hat Enterprise Linux Server release 7.4 (Maipo)

Comment 12 Nikolai Sednev 2017-12-19 17:46:05 UTC
Moving to verified due to all 4 deployment types passed successfully (
NFS, iSCSI, FC, Gluster).

Comment 13 Sandro Bonazzola 2017-12-20 10:46:54 UTC
This bugzilla is included in oVirt 4.2.0 release, published on Dec 20th 2017.

Since the problem described in this bug report should be
resolved in oVirt 4.2.0 release, published on Dec 20th 2017, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.