Bug 151119 - Good: Reboot failure
Good: Reboot failure
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.0
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Jason Baron
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-14 19:48 EST by Homayoun Shahri
Modified: 2013-03-06 00:58 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 12:57:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Homayoun Shahri 2005-03-14 19:48:47 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041215 Firefox/1.0 Red Hat/1.0-12.EL4

Description of problem:
This problem has to do with installation of RHEL 4 on a toshiba
satellite A70 and reboot. 
In order to get the touchpad recognized I had to disable the "support
for legacy usb devices" in the bios. When I did that, I was not able
to reboot. System does init 6, and unmounts file systems, but at the
very end it just hangs, and does not display the bios screen. I have
to hold the power key for a few seconds to turn it off. It shuts down
properly though. I re-enabled the support for legacy usb devices, and
I was able to reboot, using either reboot, or shutdown -h now.
Disabled, and the same problem. This is P4-HT machine, and so I also
tried the non-smp version, giving the same result. I tried reboot=w,
as well as cold, etc. No difference. Given the same bios setup winxp
does proper reboot. My feeling is that there is something in the code
that eventually returns the control to bios that does not function
properly, or may be unloading of usb drivers or something like that.
By the way I also tried to boot with acpi=off, and still the same problem.

Version-Release number of selected component (if applicable):
kernel-2.6.9-5.EL and SMP

How reproducible:
Always

Steps to Reproduce:
1. Disable support for legacy usb devices in bios
2. Reboot
3.
    

Actual Results:  Reboot hangs at the very last step. Control is not
returned to bios or something like that.

Expected Results:  Machine should reboot properly.

Additional info:
Shutdown works fine and turns power off properly.
Comment 1 Homayoun Shahri 2005-03-15 19:18:56 EST
This problem did not exist with kernel 2.4.22+ and is only observed
when kernel 2.6.x is installed. The touchpad is not recognized, and a
solution is to disable support for legacy usb devices in bios. A
possible solution that someone has proposed (I have not verified it)
is to compile psmouse as a module and do unload/load after the boot
process. The claim is that the touchpad is then recognized. So we may
want to think about what changed in psmouse that whichever module that
caused the alps touchpad on this laptop not be recognized.
Comment 2 Dave Jones 2005-06-27 16:59:09 EDT
Was this fixed with the U1 kernel ?
Comment 3 Homayoun Shahri 2005-06-27 17:18:29 EDT
I am not sure what you mean by U1 kernel, but what I did was to rebuild 2.6.10
with psmouse as a module and load it in rc.local. Now everything works. I
believe the problem is that psmouse, when part of kernel, is loaded way too
soon, before usb drivers which cause this issue. But when support for legacy usb
devices is disabled then I believe mouse shows up as a ps2 device which is
recognized, but reboot does not function properly. I do have the latest EL
kernel installed but have not tested it to see if this problem is fixed but will
do so shortly and will report the results. 

Thanks,
Homayoun
Comment 4 Homayoun Shahri 2006-01-26 17:47:51 EST
Just to add to the above, there is now another issue which is not very
important, but worth mentioning. In that if I attempt to use USB mouse and
connect it to a USB port prior to power up, it is not always recognized. After
reboot, I have to disconnect and reconnect the mouse. This is, I believe, due to
the fact that psmouse is loaded in rc.local.

You could close this bug, since there is a work around.

Thanks,
Homayoun Shahri
Comment 5 Leonard den Ottolander 2006-02-02 04:00:04 EST
I see a similar issue. Seems to be related to the i8042 driver for kernel-2.6.9.
It causes keyboard/mouse problems, or as in this and my case reboot to fail.

Please compare bug #176611. Quite possibly the same issue.
Comment 6 Homayoun Shahri 2006-02-08 20:11:37 EST
After performing my last up2date, namely upgrading the kernel to
kernel-2.6.9-22.0.2.EL.i686, and/or the smp version the same kernel, the kernel
panics at the statment right after:
mice: PS/2 mouse device common for all mice
input: AT Translated Set 2 keyboard on isa0060/serio0 ....
The kernel panics right after whatever driver is being loaded, which may
actually be the i8042 driver. I use kernel 2.6.10, but this certainly should not
happen. I believe Leonard is correct in saying that this issue is probably
related to i8042 driver. I will build 2.6.15 to see if things do indeed improve!
Comment 7 Jiri Pallich 2012-06-20 12:57:36 EDT
Thank you for submitting this issue for consideration in Red Hat Enterprise Linux. The release for which you requested us to review is now End of Life. 
Please See https://access.redhat.com/support/policy/updates/errata/

If you would like Red Hat to re-consider your feature request for an active release, please re-open the request via appropriate support channels and provide additional supporting details about the importance of this issue.

Note You need to log in before you can comment on or make changes to this bug.