This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 151137 - description for ... is over 50 chars
description for ... is over 50 chars
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: spamassassin (Show other bugs)
rawhide
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Warren Togami
:
Depends On:
Blocks: FC5Target
  Show dependency treegraph
 
Reported: 2005-03-15 06:27 EST by Felix Schwarz
Modified: 2007-11-30 17:11 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-10-17 23:01:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
output from spamassassin --lint --debug (26.12 KB, text/plain)
2005-03-15 06:30 EST, Felix Schwarz
no flags Details

  None (edit)
Description Felix Schwarz 2005-03-15 06:27:00 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; de-DE; rv:1.7.6) Gecko/20050223 Firefox/1.0.1

Description of problem:
Some of the default rules doesn't pass the SpamAssassin checks (spamassassin --lint). Therefore it isn't possible to use the rules du jour.

It seems that some rule descriptions are simply too long.
warning: description for ... is over 50 chars


Version-Release number of selected component (if applicable):
SpamAssassin 3.0.1, Perl 5.8.5

How reproducible:
Always

Steps to Reproduce:
1. spamassassin --lint --debug


Actual Results:  I will attach a log after submitting

Expected Results:  no warnings about non-existing rules and all descriptions below 50 chars.

Additional info:
Comment 1 Felix Schwarz 2005-03-15 06:30:34 EST
Created attachment 112011 [details]
output from spamassassin --lint --debug

The lines "length is: xx chars" have been added by me by patching Parser.pm in
order to see how long the description is. Please note that there are four
descriptions for non-existant rules ("warning: description exists for
non-existent ...").
Comment 2 Felix Schwarz 2005-03-15 06:41:03 EST
After some debugging I think I found the error source. It seems to be a locale
issue.

[root@ipx10171 rules]# locale
LANG=de_DE.UTF-8
(...)

[root@ipx10171 rules]# grep -i HTML_SHOUTING4 /usr/share/spamassassin/*
/usr/share/spamassassin/20_html_tests.cf:body HTML_SHOUTING4           
eval:html_range('max_shouting','3','4')
/usr/share/spamassassin/20_html_tests.cf:describe HTML_SHOUTING4               
HTML has very strong "shouting" markup
/usr/share/spamassassin/30_text_de.cf:lang de describe HTML_SHOUTING4 Viele
visuell auffällige ("schreiende") HTML-Elemente
(...)

perl -e "print length('Viele visuell auffällige (\"schreiende\") HTML-Elemente');"
53
perl -e "print length('HTML has very strong \"shouting\" markup');"
38

Obviously there is an error in the translation of the rule description (longer
than 50 chars).

A diff -u 30_text_de.cf /usr/share/spamassassin/30_text_de.cf shows that there
is no notable difference between the upstream version (first file, default
SpamAssassin 3.0.1) and the Fedora version. Therefore this bug exists in
UPSTREAM too.

As you can see below the bug is still present in the current SpamAssassin version.
cd Mail-SpamAssassin-3.0.2/rules
diff -u 30_text_de.cf ~/Mail-SpamAssassin-3.0.1/rules/30_text_de.cf
(no output)

I will file a bug in the SpamAssassin Bugzilla.

Comment 3 Felix Schwarz 2005-03-15 06:48:58 EST
The issue is being discussed in the SpamAssassin Bugzilla:
http://bugzilla.spamassassin.org/show_bug.cgi?id=4040
Comment 4 Justin Mason 2005-03-15 12:23:47 EST
already fixed upstream in 3.1.0 svn trunk.
Comment 5 Warren Togami 2005-10-17 23:01:44 EDT
Fixed in rawhide, and not worth fixing in earlier spamassassin-3.0.x

Note You need to log in before you can comment on or make changes to this bug.