Bug 151139 - tcp_wrappers isn't rebuildable against Rawhide
Summary: tcp_wrappers isn't rebuildable against Rawhide
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: tcp_wrappers   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Thomas Woerner
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-03-15 11:33 UTC by Robert Scheck
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-21 11:08:50 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Robert Scheck 2005-03-15 11:33:00 UTC
Description of problem:
tcp_wrappers isn't rebuildable against Rawhide, fails with this 
errors:

--- snipp ---
[...]
cc -DFACILITY=LOG_AUTHPRIV       -DHOSTS_ACCESS  -DNETGROUP    -
DDAEMON_UMASK=022 -DREAL_DAEMON_DIR=\"/usr/sbin\" -DPROCESS_OPTIONS -
DKILL_IP_OPTIONS -DSEVERITY=LOG_INFO       -DRFC931_TIMEOUT=10  -
DHOSTS_DENY=\"/etc/hosts.deny\" -DHOSTS_ALLOW=\"/etc/hosts.allow\"   
-O2 -Wall -g -pipe -Wp,-D_FORTIFY_SOURCE=2 -m32 -march=i386 -
mtune=pentium4 -fPIC -DPIC -D_REENTRANT -DHAVE_STRERROR  -fPIC -DPIC 
-D_REENTRANT -DSYS_ERRLIST_DEFINED -DBROKEN_SO_LINGER -DINET6=1 -
Dss_family=__ss_family -Dss_len=__ss_len -DHAVE_WEAKSYMS -DAPPEND_DOT   
-c hosts_access.c
hosts_access.c:46:20: error: macro "fgets" requires 3 arguments, but 
only 1 given
hosts_access.c:46: error: 'fgets' redeclared as different kind of 
symbol
/usr/include/stdio.h:529: error: previous declaration of 'fgets' was 
here
hosts_access.c: In function 'host_match':
hosts_access.c:298: warning: implicit declaration of function 
'yp_get_default_domain'
hosts_access.c: In function 'string_match':
hosts_access.c:337: warning: implicit declaration of function 
'match_pattern_ylo'
hosts_access.c: In function 'masked_match6':
hosts_access.c:478: warning: implicit declaration of function 'atoi'
make[1]: *** [hosts_access.o] Error 1
make[1]: Leaving directory `/usr/src/redhat/BUILD/tcp_wrappers_7.6'
make: *** [linux] Error 2
--- snapp ---

Version-Release number of selected component (if applicable):
tcp_wrappers-7.6-38

How reproducible:
Everytime, try to rebuild tcp_wrappers.

Actual results / Expected results:
tcp_wrappers should be rebuildable.

Comment 1 Robert Scheck 2005-03-21 11:08:50 UTC
Out of date, because of glibc-2.3.4-15:

- with -D_FORTIFY_SOURCE=*, avoid defining read and a bunch of others
  as function-like macros, there are too many broken programs
  out there

Closing now.


Note You need to log in before you can comment on or make changes to this bug.