Bug 151140 - freetype isn't rebuildable against Rawhide
Summary: freetype isn't rebuildable against Rawhide
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: freetype   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Zeuthen
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-03-15 11:47 UTC by Robert Scheck
Modified: 2013-03-06 03:42 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-21 11:26:18 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Robert Scheck 2005-03-15 11:47:28 UTC
Description of problem:
freetype isn't rebuildable against Rawhide, fails with this errors:

--- snipp ---
[...]
 gcc -pedantic -ansi -I/usr/src/redhat/BUILD/freetype-2.1.9/objs -
I./builds/unix -I/usr/src/redhat/BUILD/freetype-2.1.9/include -c -
Wall -O2 -Wall -g -pipe -Wp,-D_FORTIFY_SOURCE=2 -m32 -march=i386 -
mtune=pentium4 -fno-strict-aliasing -DFT_CONFIG_OPTION_SYSTEM_ZLIB -
DDARWIN_NO_CARBON "-DFT_CONFIG_CONFIG_H=
<ftconfig.h>" /usr/src/redhat/BUILD/freetype-2.1.9/src/gzip/ftgzip.c  
-fPIC -DPIC -o /usr/src/redhat/BUILD/freetype-
2.1.9/objs/.libs/ftgzip.o
/usr/src/redhat/BUILD/freetype-2.1.9/src/gzip/ftgzip.c:358:48: error: 
macro "read" passed 4 arguments, but takes just 3
/usr/src/redhat/BUILD/freetype-2.1.9/src/gzip/ftgzip.c: In function 
'ft_gzip_file_fill_input':
/usr/src/redhat/BUILD/freetype-2.1.9/src/gzip/ftgzip.c:357: warning: 
assignment makes integer from pointer without a cast
make: *** [/usr/src/redhat/BUILD/freetype-2.1.9/objs/ftgzip.lo] Error 
1
make: *** Waiting for unfinished jobs....
--- snapp ---

Version-Release number of selected component (if applicable):
freetype-2.1.9-2

How reproducible:
Everytime, try to rebuild freetype.

Actual results / Expected results:
freetype should be rebuildable.

Comment 1 Robert Scheck 2005-03-21 11:26:18 UTC
Out of date, because of glibc-2.3.4-15:

- with -D_FORTIFY_SOURCE=*, avoid defining read and a bunch of others
  as function-like macros, there are too many broken programs
  out there

Closing now.


Note You need to log in before you can comment on or make changes to this bug.