Bug 1511437 - more specific file context pattern for /run/ebtables.lock is missing
Summary: more specific file context pattern for /run/ebtables.lock is missing
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: selinux-policy
Version: 7.5
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Lukas Vrabec
QA Contact: Milos Malik
URL:
Whiteboard:
: 1581613 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-09 11:23 UTC by Milos Malik
Modified: 2018-10-30 10:02 UTC (History)
6 users (show)

Fixed In Version: selinux-policy-3.13.1-197.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-10-30 10:01:27 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:3111 None None None 2018-10-30 10:02:38 UTC

Description Milos Malik 2017-11-09 11:23:18 UTC
Description of problem:
# sesearch -s iptables_t -t var_run_t -T
Found 1 semantic te rules:
   type_transition iptables_t var_run_t : file iptables_var_run_t; 
# semanage fcontext -l | grep run/ebtables
#

Version-Release number of selected component (if applicable):
selinux-policy-3.13.1-177.el7.noarch
selinux-policy-sandbox-3.13.1-177.el7.noarch
selinux-policy-devel-3.13.1-177.el7.noarch
selinux-policy-doc-3.13.1-177.el7.noarch
selinux-policy-mls-3.13.1-177.el7.noarch
selinux-policy-minimum-3.13.1-177.el7.noarch
selinux-policy-targeted-3.13.1-177.el7.noarch

How reproducible:
* always

Steps to Reproduce:
# ls -Z /run/ebtables.lock 
-rw-------. root root system_u:object_r:iptables_var_run_t:s0 /run/ebtables.lock
# restorecon -v /run/ebtables.lock
restorecon reset /run/ebtables.lock context system_u:object_r:iptables_var_run_t:s0->system_u:object_r:var_run_t:s0
#

Actual results:
 * restorecon changes the label

Expected results:
 * restorecon does not change the label

Comment 3 Lukas Vrabec 2018-05-23 13:50:04 UTC
*** Bug 1581613 has been marked as a duplicate of this bug. ***

Comment 7 errata-xmlrpc 2018-10-30 10:01:27 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:3111


Note You need to log in before you can comment on or make changes to this bug.