Bug 15115 - /var/httpd should be used as documentroot
Summary: /var/httpd should be used as documentroot
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: apache (Show other bugs)
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
low
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact:
URL:
Whiteboard:
Keywords: FutureFeature
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-08-02 13:06 UTC by Arenas Belon, Carlo Marcelo
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-02 15:55:58 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Arenas Belon, Carlo Marcelo 2000-08-02 13:06:07 UTC
the old /home/httpd directory was broken because that won't permit /home to
be automounted.

/var is the right place as explained on FHS2.1

taking that BIND has been using /var/named as a human manipulable data
directory, apache should be using /var/httpd (named after the daemon name
as in bind) instead of the current /var/www.

Comment 1 Nalin Dahyabhai 2000-08-02 15:55:56 UTC
The name "httpd" is what Apache uses, and though I haven't tried most of the
alternative web servers, it's not guaranteed that they would have the same
process name.

Comment 2 Arenas Belon, Carlo Marcelo 2000-10-17 17:36:31 UTC
i'd started to like /var/www, i guess that it sounds more like /var/ftp and is
daemon agnostic :)

i've found /var/www used on other systems, so i guess it is the "standar" way to
go

you win :)

Comment 3 Bishop Clark 2001-11-08 18:08:00 UTC
Unfortunately, /var/www is in violation of FHS 2.2 : 5.1, as WWW data is neither logging data, a spool, transient files nor temporary files.

"
       /var contains variable data files.  This includes spool directories and
       files, administrative and logging data, and transient and temporary
       files.
"




Note You need to log in before you can comment on or make changes to this bug.