Bug 1511687 - Bricks dashboard: 2 Throughput panels with differing output
Summary: Bricks dashboard: 2 Throughput panels with differing output
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: web-admin-tendrl-monitoring-integration
Version: rhgs-3.3
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
: ---
Assignee: Ankush Behl
QA Contact: sds-qe-bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-09 21:05 UTC by Ju Lim
Modified: 2019-03-14 09:57 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-03-14 09:57:00 UTC


Attachments (Terms of Use)
Bricks dashboard (139.96 KB, image/png)
2017-11-09 21:05 UTC, Ju Lim
no flags Details


Links
System ID Priority Status Summary Last Updated
Github 251 None None None 2017-11-09 21:05:24 UTC

Description Ju Lim 2017-11-09 21:05:25 UTC
Created attachment 1350126 [details]
Bricks dashboard

Description of problem:
The bricks dashboard has 2 panels for Throughput with differing output.

It's unclear what the difference is at first glance. Either one of them needs a different label, or we should only have 1 of them. It would be also good to describe what they are.

Version-Release number of selected component (if applicable):


How reproducible:
Click on Bricks dashboard and any brick, and you'll see 2 dashboard panels called "Throughput."


Steps to Reproduce:
1. Click on Bricks dashboard and any brick, and you'll see 2 dashboard panels called "Throughput."
2.
3.

Actual results:
2 "Throughput" panels in the Bricks dashboard but mean different things but unclear what it is when looking at it.

Expected results:
Having a single Throughput panel.


Additional info:
See https://github.com/Tendrl/monitoring-integration/issues/251.

Comment 2 Nishanth Thomas 2017-11-13 04:28:52 UTC
I would propose to take this in a future release as we are close 3.3.1 timelines and this bug not critical enough to affect the core functionality.
We can make sure that the this is captured clearly in documentation.

Comment 3 Ju Lim 2018-01-24 18:19:38 UTC
From looking at monitoring-integration/etc/tendrl/monitoring-integration/grafana/dashboards/tendrl-gluster-bricks.json, here is what I saw:

(1) the first Throughput panel is showing the sum of Brick IOPS (read + write) for the brick path
tendrl.clusters.$cluster_id.volumes.$volume_name.nodes.$host_name.bricks.$brick_path.iops.gauge-read + tendrl.clusters.$cluster_id.volumes.$volume_name.nodes.$host_name.bricks.$brick_path.iops.gauge-write
Current Description: N/A

(2) the second Throughput panel is showing disk read and disk write based on tendrl.clusters.$cluster_id.volumes.$volume_name.nodes.$host_name.bricks.$brick_path.device..disk_octets.read and tendrl.clusters.$cluster_id.volumes.$volume_name.nodes.$host_name.bricks.$brick_path.device..disk_octets.write.
Current Description: "The Throughput panel displays brick-level read and write operations fetched using “gluster volume profile”

Perhaps calling the first Throughput panel what it's showing i.e. "IOPS" with a description of "The IOPS panel displays the sum of IOPS (read + write) for a given brick path".

Have we confirmed that we actually collect brick path IOPS data? I've not yet seen this data yet. If no, then we probably should not show it. Can someone verify please?

Comment 5 Martin Bukatovic 2019-03-14 09:57:00 UTC
Since RHGS 3.4.0 (at least since tendrl-monitoring-integration-1.6.3-7.el7rhgs.noarch), there is just single panel labeled Throughput in Brick Dashboard of RHGSWA Grafana based dashboard. This change must have landed in RHGSWA codebase via one of rebases done during 3.4.0 development.


Note You need to log in before you can comment on or make changes to this bug.