Bug 151176 - linus bk after 2.6.11 has changed disk initialization timings
Summary: linus bk after 2.6.11 has changed disk initialization timings
Status: CLOSED DUPLICATE of bug 163407
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel   
(Show other bugs)
Version: 3
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Garzik
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-03-15 17:49 UTC by Jon Smirl
Modified: 2013-07-03 02:24 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-04 18:00:01 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Jon Smirl 2005-03-15 17:49:47 UTC
This is being discussed on lkml but Jens says it is an early user space problem
not a kernel issue. Thread is: current linus bk, error mounting root

I was loading the SATA driver, ata_piix as a module on initrd. This has been
working fine for about a year. Something that went in after 2.6.11 has changed
the  timing. 

The nash script loads ata_piix and then does a mount. The device doesn't exist
for the mount to work. Adding a 1 sec pause in the nash script before mkrootdev
avoids the problem. There are comments that modprobe can now return before the
device has actually been created so this may impact all modular disk drivers.

Comment 1 Jon Smirl 2005-03-22 17:27:44 UTC
After more discussion on lkml it looks like this is a problem with mkinitrd and
udev. The script does udevstart followed by raidautorun. In my case the drive
nodes are not all there and some of the volumes don't get added to the raid group. 
mkinitrd needs to be modified to provide some synchronization with udev.

The sleep works because it lets udev run. The sleep is not a reliable solution
since it may take more than 1 sec for udev to run.

The change after 2.6.11 has altered things so that the raidautorun task now runs
before udev. 

Comment 2 Dave Jones 2005-07-15 20:36:41 UTC
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.

Comment 3 Jon Smirl 2005-07-16 00:05:58 UTC
This is a problem with nash, initrd and udev. A new kernel isn't going to fix it.

Comment 4 Dave Jones 2005-08-04 18:00:01 UTC
An mkinitrd update has been pushed. Update that, then remove and reinstall the
kernel, and it should work.


*** This bug has been marked as a duplicate of 163407 ***


Note You need to log in before you can comment on or make changes to this bug.