Bug 151188 - Unable to set serial number for certificate by using provided Makefile
Unable to set serial number for certificate by using provided Makefile
Status: CLOSED RAWHIDE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: openssl (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Tomas Mraz
Brian Brock
:
Depends On:
Blocks: 152485
  Show dependency treegraph
 
Reported: 2005-03-15 15:49 EST by Milan Kerslager
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version: openssl-0.9.7f-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-30 06:27:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
A patch to be able to change serial number for self signed certificate (1.70 KB, patch)
2005-03-15 15:52 EST, Milan Kerslager
no flags Details | Diff

  None (edit)
Description Milan Kerslager 2005-03-15 15:49:02 EST
When one generates self-signed certificate with provided Makefile by following
http://www.redhat.com/docs/manuals/enterprise/RHEL-4-Manual/sysadmin-guide/s1-secureserver-selfsigned.html,
this leads to have troubles with Mozilla and Firefox because the same serial
number after second use. Please patch provided /usr/share/ssl/certs/Makefile to
allow simple passing serial number to the generating process for self signed
certificates.

I'll fill a bug against RHEL-SAG to point to this problem too.
Comment 1 Milan Kerslager 2005-03-15 15:52:53 EST
Created attachment 112031 [details]
A patch to be able to change serial number for self signed certificate
Comment 2 Milan Kerslager 2005-03-15 16:09:35 EST
See the bug #151190 for RFE for RHEL-SAG (System Administration Guide).
Comment 3 Tomas Mraz 2005-03-30 06:28:16 EST
Patch applied to FC - development. Thank you.

Note You need to log in before you can comment on or make changes to this bug.