Bug 1511885 - Automatically load /usr/lib/sysctl.d/70-dirsrv.conf after installing 389-ds-base
Summary: Automatically load /usr/lib/sysctl.d/70-dirsrv.conf after installing 389-ds-base
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: 389-ds-base
Version: 7.5
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: rc
: ---
Assignee: mreynolds
QA Contact: Viktor Ashirov
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-10 11:10 UTC by Marc Muehlfeld
Modified: 2018-04-10 14:22 UTC (History)
3 users (show)

Fixed In Version: 389-ds-base-1.3.7.5-11.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-10 14:21:13 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:0811 None None None 2018-04-10 14:22:03 UTC

Description Marc Muehlfeld 2017-11-10 11:10:15 UTC
Description of problem:
The 389-ds-base package in RHEL 7.5 Beta creates the /usr/lib/sysctl.d/70-dirsrv.conf which contains optimized Kernel settings. However, they are not used by the Kernel before you either run
# sysctl -p /usr/lib/sysctl.d/70-dirsrv.conf
or reboot the system.



Version-Release number of selected component (if applicable):
389-ds-base-1.3.7.5-9.el7.x86_64



How reproducible:
Always.



Steps to Reproduce:
1. Install 389-ds-base/RHDS on RHEL 7.5 Beta
2. Display the current value of e. g. net.ipv4.tcp_fastopen, that is used by the Kernel right after the installation:
   # sysctl net.ipv4.tcp_fastopen
   Shows 0 (default), but should be 1027 (according to 70-dirsrv.conf)



Actual results:
The values from /usr/lib/sysctl.d/70-dirsrv.conf are not used by the Kernel right after the installation.



Expected results:
The RPM should automatically run
# sysctl -p /usr/lib/sysctl.d/70-dirsrv.conf
after the installation to make the new Kernel settings available, without rebooting or manually running this command.

Comment 2 wibrown@redhat.com 2017-11-13 00:38:38 UTC
Upstream ticket:
https://pagure.io/389-ds-base/issue/49449

Comment 4 Viktor Ashirov 2018-01-02 15:29:32 UTC
Build tested:
389-ds-base-1.3.7.5-11.el7.x86_64

[root@rhel7 ~]# sysctl vm.swappiness net.ipv4.tcp_slow_start_after_idle net.ipv4.tcp_fastopen net.ipv4.tcp_fin_timeout net.ipv4.tcp_keepalive_time net.ipv4.tcp_max_tw_buckets net.ipv4.tcp_max_syn_backlog net.core.default_qdisc
vm.swappiness = 30
net.ipv4.tcp_slow_start_after_idle = 1
net.ipv4.tcp_fastopen = 0
net.ipv4.tcp_fin_timeout = 60
net.ipv4.tcp_keepalive_time = 7200
net.ipv4.tcp_max_tw_buckets = 8192
net.ipv4.tcp_max_syn_backlog = 128
net.core.default_qdisc = pfifo_fast

[root@rhel7 ~]# yum install 389-ds-base -y

...

[root@rhel7 ~]# sysctl vm.swappiness net.ipv4.tcp_slow_start_after_idle net.ipv4.tcp_fastopen net.ipv4.tcp_fin_timeout net.ipv4.tcp_keepalive_time net.ipv4.tcp_max_tw_buckets net.ipv4.tcp_max_syn_backlog net.core.default_qdisc
vm.swappiness = 20
net.ipv4.tcp_slow_start_after_idle = 0
net.ipv4.tcp_fastopen = 1027
net.ipv4.tcp_fin_timeout = 30
net.ipv4.tcp_keepalive_time = 300
net.ipv4.tcp_max_tw_buckets = 262144
net.ipv4.tcp_max_syn_backlog = 4096
net.core.default_qdisc = fq_codel


Marking as VERIFIED.

Comment 7 errata-xmlrpc 2018-04-10 14:21:13 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:0811


Note You need to log in before you can comment on or make changes to this bug.