Bug 151194 - perl-RPM2 installs into site_perl; should set INSTALLDIRS=vendor
perl-RPM2 installs into site_perl; should set INSTALLDIRS=vendor
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: perl-RPM2 (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jason Vas Dias
: EasyFix
Depends On:
Blocks: FC5Target
  Show dependency treegraph
 
Reported: 2005-03-15 17:30 EST by Matthew Miller
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: perl-RPM2-0.66-12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-09 12:02:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Miller 2005-03-15 17:30:13 EST
Perl modules managed by RPM should be installed into vendor_perl, not site_perl.
Almost all modules have been updated to correct this; this is one of two in the
development tree that doesn't seem to be fixed yet.
Comment 1 Jason Vas Dias 2006-03-09 12:02:41 EST
perl-RPM2 is now deprecated (no longer shipped as part of Fedora Core). 
With the latest version of the .spec file submitted for Fedora Extras
consideration, this problem does not occur (installs correctly in vendorlib).
Comment 2 Jose Pedro Oliveira 2006-03-09 12:16:42 EST
Jason,

(In reply to comment #1)
> perl-RPM2 is now deprecated (no longer shipped as part of Fedora Core). 
> With the latest version of the .spec file submitted for Fedora Extras
> consideration, this problem does not occur (installs correctly in vendorlib).

I don't mind help reviewing it but I still haven't found a ticket for it.

/jpo

Note You need to log in before you can comment on or make changes to this bug.