Bug 151232 - Boot CD won't eject when choosing CD-ROM installation method
Boot CD won't eject when choosing CD-ROM installation method
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
4
powerpc Linux
medium Severity medium
: ---
: ---
Assigned To: Paul Nasrat
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-16 04:36 EST by Gabriel Labelle
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-06-28 11:59:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gabriel Labelle 2005-03-16 04:36:49 EST
Description of problem:

I was unable to boot from the FC4-test1-ppc-DVD, so I used the boot.iso in order
to create a bootable CD. When I choose to install from CD, my powerbook G4 17"
1.5GHz doesn't eject the CD when asking for the Fedora CD.

No tty is yet available at this point.

I had to install over http. I guess the CD has to be ejected at the end of the
installation process before Reboot, and it doesn't.

Version-Release number of selected component (if applicable):

Version included in FC4-test1-ppc.

How reproducible:

Everytime

Steps to Reproduce:

1. Boot from FC4-test1 boot CD (boot.iso);
2. Choose the CD-ROM installation method.
  
Actual results:

eject failed

Expected results:

the CD is ejected

Additional info:

Also, why can't we boot from the DVD? Maybe it has something to do with the DVD
standards supported by my powerbook's superdrive?

Many thanks for your time and help
Comment 1 Paul Nasrat 2005-03-16 05:03:00 EST
OK I see what is happening here.  Can you just confirm if in tty3 you get an
eject failed message - and transcribe that here.
Comment 2 Gabriel Labelle 2005-03-16 05:21:27 EST
Yes I verified that log and it was saying "eject failed". Unfortunatly I'm not
home, so I'll paste the exact output later today. (I'm in Paris, GMT+1)
Comment 3 Paul Nasrat 2005-03-16 09:56:33 EST
For those having issues with eject who can't do a network install

Here is a 32 bit image that will boot your mac off a usb key

It's a hd image with mac partition table, a hfs apple_bootstrap and an
ext2 partition with the kernel/initrd.  Created on an x86 linux box with
parted, hfsutils, and offset loopback mount for the ext2 parts.

http://people.redhat.com/pnasrat/ppcboot.img

0074caa1772d12ee969decb9c222614b47cb7d67  ppcboot.img

dd if=ppcboot.img of=/dev/sda bs=1k

where sda is your usb storage device 

pop the usb key into your mac.  Power up holding the option key (alt)
down and you should get the graphical chooser.  Choose the disk with the
USB logo below it and the small tux log.

Click on the -> arrow and it should take you there.
Comment 4 Paul Nasrat 2005-03-21 12:17:50 EST
Commited fix to HEAD to leave device node so we can eject it.
Comment 5 Colin Charles 2005-06-25 08:04:50 EDT
Looks like we fixed this in FC-4. CLOSED -> CURRENTRELEASE ?

Note You need to log in before you can comment on or make changes to this bug.