Bug 15124 - Xwrapper hangs in 4.0.1!
Summary: Xwrapper hangs in 4.0.1!
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: XFree86   
(Show other bugs)
Version: 1.0
Hardware: i386 Linux
high
high
Target Milestone: ---
Assignee: Preston Brown
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-08-02 14:27 UTC by Sammy
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-03 19:54:34 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Sammy 2000-08-02 14:27:55 UTC
I have installed the 4.0.1 rpm's from rawhide. When I did startx or
xinit the X initialization just hanged. It keeps saying "waiting for
X server....." and never comes up.

I recompiled from rpm source and had the same problem.

I noticed that XFree86 itself was working and the problem was Xwrapper.

I removed the ling X --> Xwrapper and replaced it with X --> XFree86
and startx and xinit now works.

Please let me know how I can fix Xwrapper compilation to correct the
problem.

Comment 1 Bill Nottingham 2000-08-02 16:48:38 UTC
Do you have the latest PAM installed?

Comment 2 Sammy 2000-08-02 19:32:17 UTC
I was using pam-0.72-20 BUT I just upgraded XFree86 to the versions on
6.9.5 beta (-0.37) and pam-0.72-23 and I have the same problem with the
same solution. If I try to play with pam.d/xserver file I do get an error
message if there is anything wrong (I intentionally put something wrong),
so this is being read it seems like.

Comment 3 Bill Nottingham 2000-08-02 23:30:34 UTC
What do the permissions on:

/usr/X11R6/bin/Xwrapper
/tmp/.X11-unix

look like?

Comment 4 Sammy 2000-08-03 13:18:25 UTC
-rws--x--x    1 root     root         6024 Jul 25 01:19 /usr/X11R6/bin/Xwrapper*
drwxrwxrwt    2 root     root         1024 Aug  2 14:31 .X11-unix/ 
srwxrwxrwx    1 root     root            0 Aug  2 14:31 X0=

Comment 5 Sammy 2000-08-03 13:20:34 UTC
By the way before I upgraded X to 4.0.1 I had the latest 4.0 version
from rawhide working i.e. everything else upgraded 4.0 was working
correctly!

Comment 6 Sammy 2000-08-03 13:29:39 UTC
One more.....I had posted this to the news group and at least one more
person is reporting the same problem with same solution!

Comment 7 Sammy 2000-08-03 19:54:32 UTC
OK.....I think I understand what is going on:

When invoked Xwrapper executes /etc/X11/X which is a link to /usr/X11R6/bin/X.
BUT in /usr/X11R6/bin  X is a link to Xwrapper!!! So, Xwrapper calls
Xwrapper and on and on. If you called X it is the same story since X is
linked to Xwrapper which then executes /etc/X11/X which is Xwrapper!!!!

The proper way to handle this is to make X a link to XFree86 and replace
all calls to X by calls to Xwrapper, for example /etc/X11/xdm/xservers file.
This is working for me. I presume xinit (called by startx) calls Xwrapper.

Or make Xwrapper call directly /usr/X11R6/bin/XFree86.

Let me know if this is correct.

Comment 8 Bill Nottingham 2000-08-14 21:29:09 UTC
How did /etc/X11/X get to be a symlink to /usr/X11R6/bin/X?

That is broken, as you've noticed. Both Xconfigurator
and the installer should be making those links correctly.

If you can reproduce this on the current rawhide
*after* running Xconfigurator, please re-open.


Note You need to log in before you can comment on or make changes to this bug.