Bug 151252 - switching from X to virtual console gives blank screen with green border
switching from X to virtual console gives blank screen with green border
Status: CLOSED DUPLICATE of bug 153729
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
: Triaged
: 151336 (view as bug list)
Depends On: libvgahw
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-16 08:31 EST by Michael Schwendt
Modified: 2007-11-30 17:11 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-11 08:18:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
X log file (37.64 KB, text/plain)
2005-03-16 08:36 EST, Michael Schwendt
no flags Details
Xorg.0.log for first crash - using startx (30.92 KB, text/plain)
2005-03-18 13:05 EST, Jim Cornette
no flags Details

  None (edit)
Description Michael Schwendt 2005-03-16 08:31:34 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.7.6) Gecko/20050302 Firefox/1.0.1 Fedora/1.0.1-1.3.2

Description of problem:
Lots of weird issues while rhgb and X server are started. First a blue screen, then a black screen with blue border. Later when X is restarted, a green screen, then a black screen with green border. Finally, GDM starts up fine. Since this was first boot, and firstboot helper tool was not started, I haven't had the chance to create an ordinary user account. Hence I switched to virtual console and got nothing then a black screen with bright green border. (Unrelated: I then tried to log into X as root, gdm went away but nothing happened. No GNOME startup at all.)

Second attempt: Reboot into run-level 3. Text mode console was fine and usable. Started system-config-display. Saw same symptoms as earlier. Blue screen, then black screen with blue border, etc. The tool started fine though, I switched resolution to 1280x1024 and exited. Back to virtual console, display and font were messed up completely. Lots of grey lines and artifacts all over the screen. No single character was readable anymore. And the screen was surrouned with a bright green border again.

* Xorg.0.log attached.

* FC3 lspci output for graphics adapter:

01:00.0 VGA compatible controller: Matrox Graphics, Inc. MGA G400 AGP (rev 04) (prog-if 00 [VGA])
        Subsystem: Matrox Graphics, Inc. Millennium G400 16Mb SGRAM
        Flags: bus master, medium devsel, latency 64, IRQ 11
        Memory at dc000000 (32-bit, prefetchable) [size=32M]
        Memory at dfefc000 (32-bit, non-prefetchable) [size=16K]
        Memory at df000000 (32-bit, non-prefetchable) [size=8M]
        Expansion ROM at dfee0000 [disabled] [size=64K]
        Capabilities: [dc] Power Management version 2
        Capabilities: [f0] AGP version 2.0


Version-Release number of selected component (if applicable):
xorg-x11-6.8.2-7

How reproducible:
Always

Steps to Reproduce:
-
  

Additional info:
Comment 1 Michael Schwendt 2005-03-16 08:35:23 EST
Can't attach anything currently. Error: You did not specify a file to attach.
Old bugzilla gives server error.
Comment 2 Michael Schwendt 2005-03-16 08:36:41 EST
Created attachment 112048 [details]
X log file
Comment 3 Anthony Green 2005-03-17 13:34:56 EST
*** Bug 151336 has been marked as a duplicate of this bug. ***
Comment 4 Jim Cornette 2005-03-18 13:00:38 EST
Using xorg-x11-6.8.2-10 and switching to a virtual terminal leaves a blue border
around the edges of the terminal. The information is not updated. There is data
on the screen though. The data is just missing the outer edges.
Additionally, the i810 driver is broken again.

00:02.0 VGA compatible controller: Intel Corporation 82815 CGC [Chipset Graphics
Controller] (rev 02) (prog-if 00 [VGA])
        Subsystem: Intel Corporation: Unknown device 0200
        Control: I/O+ Mem+ BusMaster+ SpecCycle- MemWINV- VGASnoop- ParErr-
Stepping- SERR- FastB2B-
        Status: Cap+ 66Mhz+ UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort-
<TAbort- <MAbort- >SERR- <PERR-
        Latency: 0
        Interrupt: pin A routed to IRQ 11
        Region 0: Memory at f8000000 (32-bit, prefetchable) [size=64M]
        Region 1: Memory at ffa80000 (32-bit, non-prefetchable) [size=512K]
        Capabilities: <available only to root>
Comment 5 Jim Cornette 2005-03-18 13:05:56 EST
Created attachment 112135 [details]
Xorg.0.log for first crash - using startx

The symptoms were striped lines and a movable mouse button. After
ctl-alt-backspace, the blue border still outlined the screen.

The problen seems to be present with or without X running, once X was started.
Comment 6 Jim Cornette 2005-03-18 14:57:59 EST
Adding to CC:

Also others seem to have the border. The difference seems to be on the border
color, if text is normal within the border, not seen at all or washed out. An S3
video card was also reported as being washed out w/ a blue border on system
shutdown. (No vt switching)
Comment 7 Michael Rommel 2005-03-27 20:34:43 EST
Same problem here with an Matrox PCI G400 dualhead card. Once X starts it runs
okay (well, the mouse won't move from one screen to the next and the wacom
driver does not move the pointer a bit). Switching to any VC messes up the
screen, bright green border, no contents. Can type into the VC and the commands
are accepted, though. Switching to VC 7 brings X back again, no problems.
On-Board video chipset on the board (VIA Epia M6000) is not connected to any
monitor. 
Comment 8 Colin Charles 2005-04-07 09:09:19 EDT
I don't see a messed vc1-6, but it surely doesn't show itself. Only vt7 works
(X). Can reproduce this on several x86 boxes, and even ppc...

Similar to bug #153729 (thats quite possibly a dup to this)
Comment 9 David Bentley 2005-04-08 18:48:14 EDT
I am seeing this also on my test machine with a MATROX G400 card.

it manifests itself as a black screen with a solid green border when selecting
consoles 1-6 but something similar is seen breifly at boot and shutdown but this
time a blue border is seen.
Comment 10 Mike A. Harris 2005-04-11 06:05:25 EDT
The initial report is unreadable, please restate the problem in a new
comment, and hit the ENTER key after every 60 chars or so please.

Thanks in advance.

Setting status to NEEDINFO, awaiting update.
Comment 11 Michael Schwendt 2005-04-11 07:17:56 EDT
The requirement to insert linebreaks manually is NEW and annoying.
It's a broken bugzilla update.

[...]

Lots of weird issues while rhgb and X server are started. First a blue screen,
then a black screen with blue border. Later when X is restarted, a green screen,
then a black screen with green border. Finally, GDM starts up fine. Since this
was first boot, and firstboot helper tool was not started, I haven't had the
chance to create an ordinary user account. Hence I switched to virtual console
and got nothing then a black screen with bright green border. (Unrelated: I then
tried to log into X as root, gdm went away but nothing happened. No GNOME
startup at all.)

Second attempt: Reboot into run-level 3. Text mode console was fine and usable.
Started system-config-display. Saw same symptoms as earlier. Blue screen, then
black screen with blue border, etc. The tool started fine though, I switched
resolution to 1280x1024 and exited. Back to virtual console, display and font
were messed up completely. Lots of grey lines and artifacts all over the screen. 
No single character was readable anymore. And the screen was surrouned with a
bright green border again.
Comment 12 Mike A. Harris 2005-04-11 08:16:36 EDT
>The requirement to insert linebreaks manually is NEW and annoying.
>It's a broken bugzilla update.

It must be your web browser perhaps. I never experience this problem using
firefox or mozilla.  It wont let me type past the right side of the text box.

Sometimes I want to have text extend beyond the normal right column, such
as code or unified diffs, and bugzilla never permits it.  I'm not sure
how others even get it to do this without trying.  ;o)
Comment 13 Mike A. Harris 2005-04-11 08:18:01 EDT
This appears to be a duplicate of bug #153729.
Comment 14 Mike A. Harris 2005-04-11 08:18:40 EDT

*** This bug has been marked as a duplicate of 153729 ***
Comment 15 Anthony Green 2005-04-11 08:27:10 EDT
(In reply to comment #12)
> >The requirement to insert linebreaks manually is NEW and annoying.
> >It's a broken bugzilla update.
> 
> It must be your web browser perhaps. I never experience this problem using
> firefox or mozilla.  It wont let me type past the right side of the text box.

No, I have the same problem.  The comment entry form _does_ wordwrap, but the
resulting text isn't wrapped.  This is with FC3/firefox.

Here's the same text with forced newlines so you can read it :-)

No, I have the same problem.  The comment entry form _does_ wordwrap,
but the resulting text isn't wrapped.  This is with FC3/firefox.
Comment 16 Anthony Green 2005-04-11 08:29:00 EDT
Bah.  It looks like bugzilla was fixed.  I see my text was word-wrapped in both
cases.  Many bugs filed in the last couple of weeks didn't work this way. 
Comment 17 Michael Schwendt 2005-04-11 11:17:46 EDT
> It must be your web browser perhaps.

Firefox from Fedora Core 3 (or FC4T1), see "Bugzilla Helper" info in bug report.

User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.7.6) Gecko/20050302
Firefox/1.0.1 Fedora/1.0.1-1.3.2

> This appears to be a duplicate of bug #153729

Sorry that I filed this as bug 151252 because my crystal ball failed to tell me
that somebody else would file it three weeks later. ;)
Comment 18 Mike A. Harris 2005-04-11 14:56:47 EDT
>Sorry that I filed this as bug 151252 because my crystal ball failed to tell me
>that somebody else would file it three weeks later. ;)

Heh...  sorry, that wasn't the intention..  When we notice 2 or more bugs
as duplicates of each other, we try to pick the bug with the most information
or most useful information in it as a master duplicate to close the others
as dupes against.  If no particular bug contains more information than another
or if they're all relatively similar, we generally just pick one at random
in no particular order.  ;o)

So, while it might seem we're suggesting you should have a crystal ball,
it's not quite like that.   ;o)

We only need to track a given problem in one bug report though, so feel
free to make any additional followups in the master dupe.  We can refer
back here for any info you've already supplied.

Thanks Michael! ;)

Note You need to log in before you can comment on or make changes to this bug.