Bug 151254 - "log out" does nothing, splash screen hang
"log out" does nothing, splash screen hang
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-session (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ray Strode [halfline]
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-16 09:23 EST by Need Real Name
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-11 10:35:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2005-03-16 09:23:28 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.3) Gecko/20041020 Epiphany/1.4.4

Description of problem:
This is probably a gnome bug, but because it's vnc specific I filed it here.

I have remote login using Xvnc setup. It works fine (apart from some dodgy fonts), apart from the Desktop> Log Out, which does nothing.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
x

Additional info:
Comment 1 Need Real Name 2005-03-16 09:38:33 EST
If I click "log out", then wait for a while (a few minutes), it does work.
Bizarrely, minimising vncviewer seems to speed it up.
Comment 2 Tim Waugh 2005-03-16 09:44:57 EST
I need 'steps to reproduce' here -- there are so many ways to run a VNC server,
you'll have to be specific about how you are running yours.

The key question is this: are you logged in to two GNOME sessions on the same
machine as the same user?  Or is the VNC session the only GNOME session on that
machine for that user?
Comment 3 Need Real Name 2005-03-16 09:49:16 EST
Answer to key question: This is the only Gnome session on that machine for that
user.

Reproduce:

Add to /etc/services:
 #
 # VNC Servers
 #
 vnc-800x600x16 5900/tcp
 vnc-1024x768x16 5901/tcp

Add to /etc/xinetd.d/xvncserver:
 service vnc-800x600x16
 {
  protocol = tcp
  socket_type = stream
  wait = no
  user = nobody
  server = /usr/bin/Xvnc
  server_args = -inetd -query localhost -once -geometry 800x600 -depth 16
securitytypes=none -fp unix/:7100
 }

 service vnc-1024x768x16
 {
  protocol = tcp
  socket_type = stream
  wait = no
  user = nobody
  server = /usr/bin/Xvnc
  server_args = -inetd -query localhost -once -geometry 1024x768 -depth 16
securitytypes=none -fp unix/:7100
 }

Edit /etc/X11/gdm/gdm.conf
Change "Enable=false" to "Enable=true"

Restart xinetd and gdm-binary

From remote machine, run vncviewer ip:1
Login as user, go to Desktop> Log out
Wait..
Comment 4 Tim Waugh 2005-03-16 09:54:56 EST
Okay, thanks.  You mentioned that this is VNC-specific -- what other methods of
logging in to GNOME have you tried?  Have you tried logging in over a normal
XDMCP connection, for instance?  IOW, 'X -query localhost' rather than Xvnc?
Comment 5 Need Real Name 2005-03-16 10:03:22 EST
It seems I was wrong.

On installing FC4T1, the machine crawled when it got to runlevel 5. To work
around this, I switched to runlevel 3 and ran startx manually. Using "log out"
this way worked immediately (it no longer does).

To fix this properly, I upgraded gdm and xorg-x11. Now I get the "log out" delay
problem whether local or remote.

I'm not sure if it's worth mentioning that the Fedora splash screen after login
doesn't go away until I click on it.

Thanks for the quick replies btw.
Comment 6 Tim Waugh 2005-03-16 10:24:34 EST
Okay.  The splash screen problem almost certainly is related, yes, and I expect
if you leave it long enough it will go away of its own accord -- and then log
out will not be delayed.

Reassigning to GNOME.
Comment 7 Michael McCabe 2005-03-22 09:17:13 EST
I'm getting the logout delay locally on a fresh FC4 T1 install
Comment 8 Need Real Name 2005-04-11 10:35:23 EDT
WFM

Note You need to log in before you can comment on or make changes to this bug.