Bug 1512569 - Azure - Disk properties missing or incorrect
Summary: Azure - Disk properties missing or incorrect
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers
Version: 5.8.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: GA
: 5.10.0
Assignee: Daniel Berger
QA Contact: Dave Johnson
Steve Bream
URL:
Whiteboard:
Depends On:
Blocks: 1512727 1512728
TreeView+ depends on / blocked
 
Reported: 2017-11-13 14:39 UTC by Bronagh Sorota
Modified: 2019-08-06 20:06 UTC (History)
6 users (show)

Fixed In Version: 5.10.0.0
Doc Type: Enhancement
Doc Text:
Previously, CloudForms did not display operating system disk type and tier information for instances on Azure providers. This release adds the `get_unmanaged_disk_space` setting for use with Azure providers, which is enabled by default. When enabled, the `get_unmanaged_disk_space` setting gathers the disk size and tier for unmanaged disks by logging into the Azure storage account. Note, this setting can slow down provider refresh time due to the multiple requests needed for to collect this information, and can be disabled if desired.
Clone Of:
: 1512727 1512728 (view as bug list)
Environment:
Last Closed: 2018-06-21 21:12:35 UTC
Category: ---
Cloudforms Team: Azure
Target Upstream Version:


Attachments (Terms of Use)

Description Bronagh Sorota 2017-11-13 14:39:24 UTC
Description of problem:
OS Disk size is incorrect
Disk type and tier are missing on all disk types
% Used disk space is set to 0%

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Add an Azure provider
2. Click on any instance
3. Notice the OS disk capacity is set to the capacity of the series, not the disk.
4. Notice the % used disk space is set to 0%
5. The disk type and tier are not currently gathered.

Comment 4 Daniel Berger 2017-11-13 15:37:11 UTC
Note that we've made getting unmanaged disk space a configuration setting called 'get_unmanaged_disk_space'. By default this is true.

Users may want to disable this because it does slow down refresh a bit. This is because in order to get disk information for unmanaged VM's, it requires two additional requests behind the scenes per unmanaged VM - one to get its storage account key and one to get the blob properties.


Note You need to log in before you can comment on or make changes to this bug.