Bug 15126 - lsof core dumps with "Illegal instruction"
Summary: lsof core dumps with "Illegal instruction"
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: lsof (Show other bugs)
(Show other bugs)
Version: 6.2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-08-02 15:34 UTC by marek
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-02 15:34:50 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description marek 2000-08-02 15:34:50 UTC
I'm not sure what kind of problem is this but when I run lsof with any 
parameter (except "-v" - version) it core dumps with the message "Illegal 
instruction". Here is a strace snippet :

getdents(4, /* 4 entries */, 984)       = 56
stat("/proc/1/fd/0", {st_mode=S_IFSOCK|0777, st_size=0, ...}) = 0
lstat("/proc/1/fd/0", {st_mode=S_IFLNK|0700, st_size=64, ...}) = 0
readlink("/proc/1/fd/0", "socket:[172]", 4095) = 12
--- SIGILL (Illegal instruction) ---
+++ killed by SIGILL +++

Upgrading to latest version (4.49) solved this.

I can also send in the core dump.

Comment 1 marek 2000-08-03 14:39:47 UTC
Probably caused by some hardware problems, will do some tests and report later.


Note You need to log in before you can comment on or make changes to this bug.