Bug 151285 - Using update-altenatives doesn't work
Summary: Using update-altenatives doesn't work
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: fedora-usermgmt   
(Show other bugs)
Version: 3
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Enrico Scholz
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-03-16 17:56 UTC by Mark McLoughlin
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-18 08:23:46 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fedora-usermgmt-altenatives.diff (916 bytes, patch)
2005-03-16 17:57 UTC, Mark McLoughlin
no flags Details | Diff

Description Mark McLoughlin 2005-03-16 17:56:52 UTC
If you try to use the "predictable user-creation" part of fedora-usermgmt by:

/usr/sbin/update-alternatives --set fedora-usermgmt \
     /etc/fedora/usermgmt/scripts.shadow-utils

it doesn't seem to change the behaviour at all because the wrapper script
doesn't use the alternatives indirection.

Attaching a patch which fixes it for me.

Comment 1 Mark McLoughlin 2005-03-16 17:57:37 UTC
Created attachment 112053 [details]
fedora-usermgmt-altenatives.diff

Comment 2 Enrico Scholz 2005-03-16 18:45:33 UTC
mmh... you should have a symlink

| /etc/fedora/usermgmt/scripts -> /etc/alternatives/fedora-usermgmt


which is created by the

| /usr/sbin/update-alternatives --install /etc/fedora/usermgmt/scripts fedora-usermgmt /etc/fedora/usermgmt/scripts.legacy 60

%post scriptlet of the -shadow-utils subpackage.


So the tools are right in looking for the script at
'/etc/fedora/usermgmt/scripts'. Do you have a reproducible example
which demonstrates your problems?


Comment 3 Mark McLoughlin 2005-03-18 08:23:46 UTC
Okay, apologies - this must have somehow been my mistake. It works fine just as
you describe.


Note You need to log in before you can comment on or make changes to this bug.