Bug 1512852 - avc denied for nscd, avc: denied { read } comm="nscd" name="disable_ipv6" dev="proc"
Summary: avc denied for nscd, avc: denied { read } comm="nscd" name="disable_ipv6" d...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: selinux-policy
Version: 7.5
Hardware: Unspecified
OS: Linux
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Lukas Vrabec
QA Contact: Milos Malik
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-14 09:54 UTC by Sergey Kolosov
Modified: 2018-10-30 10:01 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-10-30 10:01:27 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:3111 None None None 2018-10-30 10:01:53 UTC

Description Sergey Kolosov 2017-11-14 09:54:22 UTC
Description of problem:
I got AVC message with runned nscd after "getent" some host which doesn't have ipv6 address:

type=PROCTITLE msg=audit(1510647341.737:174): proctitle="/usr/sbin/nscd"
type=SYSCALL msg=audit(1510647341.737:174): arch=c000003e syscall=2 success=no exit=-13 a0=7f7a0e3ecf18 a1=80000 a2=1b6 a3=24 items=0 ppid=1 pid=10303 auid=4294967295 uid=28 gid=28 euid=28 suid=28 fsuid=28 egid=28 sgid=28 fsgid=28 tty=(none) ses=4294967295 comm="nscd" exe="/usr/sbin/nscd" subj=system_u:system_r:nscd_t:s0 key=(null)
type=AVC msg=audit(1510647341.737:174): avc:  denied  { read } for  pid=10303 comm="nscd" name="disable_ipv6" dev="proc" ino=7040 scontext=system_u:system_r:nscd_t:s0 tcontext=system_u:object_r:sysctl_net_t:s0 tclass=file

Version-Release number of selected component (if applicable):
selinux-policy-3.13.1-179.el7
nscd-2.17-218.el7

How reproducible:

Steps to Reproduce:
1. Install and start nscd
2. getent hosts aaa
3. ausearch -m AVC -m USER_AVC -m SELINUX_ERR

Actual results:
type=PROCTITLE msg=audit(1510647341.737:174): proctitle="/usr/sbin/nscd"
type=SYSCALL msg=audit(1510647341.737:174): arch=c000003e syscall=2 success=no exit=-13 a0=7f7a0e3ecf18 a1=80000 a2=1b6 a3=24 items=0 ppid=1 pid=10303 auid=4294967295 uid=28 gid=28 euid=28 suid=28 fsuid=28 egid=28 sgid=28 fsgid=28 tty=(none) ses=4294967295 comm="nscd" exe="/usr/sbin/nscd" subj=system_u:system_r:nscd_t:s0 key=(null)
type=AVC msg=audit(1510647341.737:174): avc:  denied  { read } for  pid=10303 comm="nscd" name="disable_ipv6" dev="proc" ino=7040 scontext=system_u:system_r:nscd_t:s0 tcontext=system_u:object_r:sysctl_net_t:s0 tclass=file

Expected results:
No AVC denials

Additional info:

Comment 5 Sergey Kolosov 2018-05-25 07:39:18 UTC
I am changing arch to unspecified because it is reproducible on all archs supported by rhel.

Comment 9 errata-xmlrpc 2018-10-30 10:01:27 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:3111


Note You need to log in before you can comment on or make changes to this bug.