Bug 1512853 - HDA output on line out jack not working
Summary: HDA output on line out jack not working
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 26
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-14 09:55 UTC by Petr Tuma
Modified: 2018-02-28 06:50 UTC (History)
20 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-02-28 06:50:15 UTC
Type: Bug


Attachments (Terms of Use)
alsa-info output on the affected machine after asound.state was removed (44.74 KB, text/plain)
2017-11-22 09:17 UTC, Petr Tuma
no flags Details

Description Petr Tuma 2017-11-14 09:55:34 UTC
Description of problem:

After kernel upgrade, Line Out output on Intel HDA chipset does not play any sound. Other outputs on the same card work, the same output with earlier kernel version works, jack plug in detection works.

Version-Release number of selected component (if applicable):

Bug first appeared with kernel 4.13.10, version 4.13.9 works.

System information:
- Dell Precision T1600 Workstation
- Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 04)

How reproducible:

Always reproducible.

Steps to Reproduce:

Boot into any kernel between 4.13.10 and 4.13.12 (most recent distributed in Fedora 26 at this time). Sound on Line Out output does not work, other outputs work. Booting kernel 4.13.9 or earlier makes sound work again. Did make sure pulse audio mixer is set correctly.

Comment 1 Laura Abbott 2017-11-14 18:45:44 UTC
There was one ALSA patch that looks suspicious, I made a revert in 
https://koji.fedoraproject.org/koji/taskinfo?taskID=23124792

Can you test this when it finishes?

Comment 2 Petr Tuma 2017-11-15 08:10:06 UTC
Thank you! Unfortunately not, the modified kernel (kernel-4.13.12-201.rhbz1512853.fc26.x86_64.rpm) still has the same problem. Is there any other modification I should try to test this ?

Comment 3 Laura Abbott 2017-11-16 20:03:33 UTC
I found one other patch that might be suspicious so I tried a revert there
https://koji.fedoraproject.org/koji/taskinfo?taskID=23164214

If this doesn't work, it should probably just go to the upstream maintainer.

Comment 4 Petr Tuma 2017-11-21 07:38:16 UTC
Success, this one was it. With 4.13.12-202.rhbz1512853 the sound is back.
Thank you!

Comment 5 Laura Abbott 2017-11-21 17:30:57 UTC
Thanks for testing, I asked the upstream maintainer and got this in response:

"It might be that the formerly saved asound.state brought the
inconsistency.  Try to remove the saved state (either
/var/lib/alsa/asound.state or /etc/asound.state) after unloading the
sound driver modules and reboot/retest.

In anyway, give alsa-info.sh output with the affected machine.
Run the script with --no-upload option, and attach the generated
file."

What I'd recommend here is:

1) Boot into the latest 4.13.x kernel (should be 4.13.13 or 4.14.14) to verify the problem is still present

2) add "module_blacklist=snd" to the kernel commandline on boot, verifiy that the sound modules didn't get loaded with lsmod (you can compare against a working kernel if you are curious)

3) rm /var/lib/alsa/asound.state 

4) Reboot without the module_blacklist on the command line

And then share the output of alsa-info.sh

Comment 6 Petr Tuma 2017-11-22 09:16:44 UTC
tl;dr: This fixed the problem, thanks!

Longer info: I've booted into 4.13.13-300.fc27 and tested that the problem still persists. Afterwards, I've removed the asound.state file (rebooted with module blacklisted, rm /var/lib/alsa/asound.state), rebooted back, this fixed the problem.

I've attached the alsa-info file in case it is still useful.

Comment 7 Petr Tuma 2017-11-22 09:17:51 UTC
Created attachment 1357317 [details]
alsa-info output on the affected machine after asound.state was removed

Comment 8 Laura Abbott 2018-02-28 03:41:10 UTC
We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale. The kernel moves very fast so bugs may get fixed as part of a kernel update. Due to this, we are doing a mass bug update across all of the Fedora 26 kernel bugs.
 
Fedora 26 has now been rebased to 4.15.4-200.fc26.  Please test this kernel update (or newer) and let us know if you issue has been resolved or if it is still present with the newer kernel.
 
If you have moved on to Fedora 27, and are still experiencing this issue, please change the version to Fedora 27.
 
If you experience different issues, please open a new bug report for those.


Note You need to log in before you can comment on or make changes to this bug.