Bug 1512948 - Default value of $releasever is set to "7.5" instead of "7$Variant"
Summary: Default value of $releasever is set to "7.5" instead of "7$Variant"
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: releng
Version: 7.5
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: rc
: ---
Assignee: Lubos Kocman
QA Contact: Release Test Team
URL:
Whiteboard:
Depends On:
Blocks: 1511273
TreeView+ depends on / blocked
 
Reported: 2017-11-14 13:46 UTC by Rehana
Modified: 2018-04-10 10:20 UTC (History)
6 users (show)

Fixed In Version: redhat-release-7.5-0.14.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-10 10:19:01 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2018:0700 None None None 2018-04-10 10:19:59 UTC

Description Rehana 2017-11-14 13:46:53 UTC
Description of problem:
Default value of $releasever is set to "7.5" instead of  "7$Variant", due to this yum repolist is failing with HTTPS Error 403 - Forbidden

Version-Release number of selected component (if applicable):
#  rpm -q redhat-release-server
redhat-release-server-7.5-0.12.el7.x86_64


How reproducible:
always

Steps to Reproduce:
1.Install RHEL75 Develphase exit build --> server variant
2.Register and subscribe system from stage
3.execute yum repolist

[root@dhcp35-157 ~]# subscription-manager register --auto-attach
Registering to: subscription.rhsm.stage.redhat.com:443/subscription
Username: user
Password: 
The system has been registered with ID: 5178ce49-d909-44fc-8015-0070453589d1
The registered system name is: dhcp35-157.lab.eng.blr.redhat.com
Installed Product Current Status:
Product Name: Red Hat Enterprise Linux Server
Status:       Subscribed

[root@dhcp35-157 ~]# yum repolist
Loaded plugins: langpacks, product-id, search-disabled-repos, subscription-manager
https://cdn.redhat.com/content/dist/rhel/server/7/7.5/x86_64/os/repodata/repomd.xml: [Errno 14] HTTPS Error 403 - Forbidden
Trying other mirror.
To address this issue please refer to the below knowledge base article

https://access.redhat.com/solutions/69319

If above article doesn't help to resolve this issue please open a ticket with Red Hat Support.

https://cdn.redhat.com/content/dist/rhel/server/7/7.5/x86_64/os/repodata/repomd.xml: [Errno 14] HTTPS Error 403 - Forbidden
Trying other mirror.
repo id     repo name                                 status
rhel-7-server-rpms/7.5/x86_64 Red Hat Enterprise Linux 7 Server (RPMs)  0
repolist: 0
^^ NOTICE 7.5 HAS BEEN USED INSTEAD OF 7SERVER, HENCE NO CONTENT AVAILABLE


Actual results:
Observed $releaserver is using the "7.5" instead of "7Server"

Expected results:
$releaserver should be using "7$Variant"

Additional info:
on a RHEL74 machine 
-----------------------
# python -c 'import yum, pprint; yb = yum.YumBase(); pprint.pprint(yb.conf.yumvar, width=1)'
Loaded plugins: product-id
{'arch': 'ia32e',
 'basearch': 'x86_64',
 'releasever': '7Server',
 'uuid': 'c83b7a2b-3414-4179-b023-1401cde881a6'}
[root@dell-pem600-01 ~]# 


ON RHEL75 
==========

# python -c 'import yum, pprint; yb = yum.YumBase(); pprint.pprint(yb.conf.yumvar, width=1)'
Loaded plugins: langpacks, product-id, subscription-manager
{'arch': 'ia32e',
 'basearch': 'x86_64',
 'releasever': '7.5',
 'uuid': 'c355538f-c3e7-4f4b-ae35-a31b507882a5'}
[root@dhcp35-157 ~]#

Comment 2 Lubos Kocman 2017-11-14 13:51:03 UTC
This needs to get fixed.

Lubos

Comment 6 Pavel Studeník 2017-11-23 12:15:13 UTC
It looks that it is not fixed for Satellite 5 https://bugzilla.redhat.com/show_bug.cgi?id=1516832

Comment 10 errata-xmlrpc 2018-04-10 10:19:01 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHEA-2018:0700


Note You need to log in before you can comment on or make changes to this bug.