Bug 1512956 - Incomplete listing for `dnf list installed`
Summary: Incomplete listing for `dnf list installed`
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf   
(Show other bugs)
Version: 27
Hardware: All
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Marek Blaha
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Triaged
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-14 13:59 UTC by Artem S. Tashkinov
Modified: 2018-06-28 08:25 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2018-06-28 08:25:52 UTC
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Artem S. Tashkinov 2017-11-14 13:59:10 UTC
# dnf list installed | egrep -v "@fedora|@updates"
Installed Packages
adobe-release-x86_64.noarch        1.0-1                                @@commandline
compat-openssl10-pkcs11-helper.x86_64
flash-plugin.x86_64                27.0.0.183-release                   @adobe-linux-x86_64
google-chrome-stable.x86_64        62.0.3202.89-1                       @google-chrome
mobile-broadband-provider-info.noarch
policycoreutils-python-utils.x86_64
python-backports-ssl_match_hostname.noarch
python3-dnf-plugin-show-leaves.noarch
python3-dnf-plugin-system-upgrade.noarch
python3-dnf-plugins-extras-common.noarch
xfce4-hardware-monitor-plugin.x86_64

So no version or repo information for eight installed packaged.

This is a bug.

This is in a fully updated Fedora 27 installation as of 2017-11-14.

Comment 1 Daniel Mach 2017-11-15 12:23:28 UTC
This has something to do with how DNF formats output.
It sometimes splits output to multiple lines, especially when using grep.
We'll fix the problem.

Comment 3 Jaroslav Mracek 2018-06-28 08:25:52 UTC
The issue is solved by dnf-3.0.1-1 that was released into rawhide.


Note You need to log in before you can comment on or make changes to this bug.