Bug 1512960 - [ceph-ansible] journal on device should be removed from osds.yml for osd scenario lvm
Summary: [ceph-ansible] journal on device should be removed from osds.yml for osd scen...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Ceph Storage
Classification: Red Hat
Component: Ceph-Ansible
Version: 3.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: z1
: 3.3
Assignee: Andrew Schoen
QA Contact: Ameena Suhani S H
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2017-11-14 14:10 UTC by Madhavi Kasturi
Modified: 2019-10-22 13:29 UTC (History)
7 users (show)

Fixed In Version: RHEL: ceph-ansible-3.2.26-1.el7cp Ubuntu: ceph-ansible_3.2.26-2redhat1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-10-22 13:29:00 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Github ceph ceph-ansible pull 2172 0 'None' 'closed' 'lvm: add support for --data to be a raw device or partition' 2019-12-02 07:29:23 UTC
Red Hat Product Errata RHBA-2019:3173 0 None None None 2019-10-22 13:29:20 UTC

Description Madhavi Kasturi 2017-11-14 14:10:37 UTC
Description of problem:
In osds.yml, for osd scenario LVM, journal on device should be removed as its not supported. 

Version-Release number of selected component (if applicable):
[root@magna100 ceph-ansible]# rpm -qa | grep ansible
ansible-2.4.1.0-1.el7ae.noarch
ceph-ansible-3.0.11-1.el7cp.noarch

How reproducible:


Steps to Reproduce:
1. osds.yml , mentions the following
# journal can be either a lv, device or partition. You can not use the same journal for many data lvs.
# data_vg must be the volume group name of the data lv
# journal_vg is optional and must be the volume group name of the journal lv, if applicable
# For example:
# lvm_volumes:
#   - data: data-lv1
#     data_vg: vg1
#     journal: journal-lv1
#     journal_vg: vg2
#   - data: data-lv2
#     journal: /dev/sda
#     data_vg: vg1

Since there is no support for journal on device. 

The same has to be removed from yml
 
1. journal can be either a lv, device or partition
2. For example section:
- data: data-lv2
#     journal: /dev/sda 

Actual results:


Expected results:


Additional info:

Comment 3 Sébastien Han 2017-11-15 09:24:50 UTC
Assigning to Andrew since he brought the ceph-volume support in ceph-ansible.

Comment 4 Andrew Schoen 2017-11-16 16:19:19 UTC
This was fixed with https://github.com/ceph/ceph-ansible/pull/2172

Comment 6 Giridhar Ramaraju 2019-08-05 13:06:00 UTC
Updating the QA Contact to a Hemant. Hemant will be rerouting them to the appropriate QE Associate. 

Regards,
Giri

Comment 7 Giridhar Ramaraju 2019-08-05 13:08:43 UTC
Updating the QA Contact to a Hemant. Hemant will be rerouting them to the appropriate QE Associate. 

Regards,
Giri

Comment 9 Ameena Suhani S H 2019-09-26 09:01:22 UTC
Verified using 

ansible-2.6.19-1.el7ae.noarch
ceph-ansible-3.2.27-1.el7cp.noarch.

Moving to VERIFIED state

Comment 11 errata-xmlrpc 2019-10-22 13:29:00 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:3173


Note You need to log in before you can comment on or make changes to this bug.