Bug 151307 - Fedora initial configuration does not appear after initial reboot
Fedora initial configuration does not appear after initial reboot
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: firstboot (Show other bugs)
4
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Lumens
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-03-16 15:21 EST by Andy Hudson
Modified: 2007-11-30 17:11 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-06 18:14:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andy Hudson 2005-03-16 15:21:17 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050302 Firefox/1.0.1 Fedora/1.0.1-1.3.2

Description of problem:
After installing FC4T1 and being prompted to remove the DVD and reboot, system goes straight to a graphical login.

The configuration part of Anaconda (ie time/date, adding users etc) does not appear.

Installation appears to be fine up until this point. When I try to login as root the screen changes colour to a darker blue (the desktop blue) but does nothing. I end up having to Ctrl-Alt-Del to get out of it.

Version-Release number of selected component (if applicable):
FC4 T1

How reproducible:
Always

Steps to Reproduce:
1. Install FC4T1
2. When prompted to remove install media, click reboot.
3. Wait for graphical login to appear.
   

Actual Results:  Graphical login comes up, no further configuration takes place

Expected Results:  Should have got the initial configuration screen (ie time/date, users etc)

Additional info:
Comment 1 Aaron Kurtz 2005-03-16 16:57:52 EST
If you install gnome-python2-gnomevfs from rawhide runlevel 5 firstboot will work.
Comment 2 Andy Hudson 2005-03-17 15:08:25 EST
Hi,

Installed the above using yum - how can I then force Rawhide to go into
firstboot mode so I can complete the configuration?
Comment 3 xander 2005-03-18 10:59:13 EST
I have the same problem which occurs:
- when upgrading fedora core 3
- when not installing gnome but kde.
After completing the first stage of the installation, before the first reboot, 
briefly an error message appears. Something about python, gnome and something 
deprecated. 
Sytem details: AMD 2200, KM7VM2, 512 MB, 2x 80 GB ata harddisk, dual boot 
(win2k)(In reply to comment #2)

Comment 4 Leon Stringer 2005-03-18 15:43:01 EST
Is the lack of firstboot stopping the GNOME login? i.e. I've installed
gnome-python2-gnomevfs but I still just get the blue background Andy reports.

Like Andy, I don't know how to kick off first boot once gnome-python2-gnomevfs
is installed.
Comment 5 xander 2005-03-18 18:43:32 EST
Yes, blue screen getting darker and then nothing happens. My comment is an 
addition to Andy's bug report. Like him I also tried installing only Gnome, 
both, but nothing seems to work.

Comment 6 Andy Hudson 2005-03-19 16:28:07 EST
OK - I installed gnome-python2-gnomevfs to my system.

When I got to the command prompt I used Ctrl-Alt F2 to drop to a console, 
logged in as root (unsafe, I know but no other choice given that there weren't 
any other users available on the system) - edited /etc/yum.conf to temporarily 
disable gpgcheck (I didn't have access to the GPG key lcoation at that time). 
typed yum install gnome-python2-gnomevfs to install that package and it's 
necessary components. After installation I created a new user using the 
useradd command.

Once this was completed I Ctrl-Alt F7'd back to my graphical login and logged 
in as the new user. Everything seemed to be fine from then on in, I just used 
Fedora's configuration tools to set resolution etc up from there.

I have since found out that you should just be able to type in firstboot at 
the command line to get the firstboot screens.

I will repeat that all I did was a standard Personal Desktop install and a 
standard Workstation install - nothing was added or taken away in custom 
packages.
Comment 7 Nicolas Scheibling 2005-03-22 16:43:20 EST
i have tried:
yum install gnome-python2-gnomevfs

but i cant launch firstboot from command line (after the install).

Note You need to log in before you can comment on or make changes to this bug.