Bug 1513132 (CVE-2017-11213, CVE-2017-11215, CVE-2017-11225, CVE-2017-3112, CVE-2017-3114) - CVE-2017-11213 CVE-2017-11215 CVE-2017-11225 CVE-2017-3112 CVE-2017-3114 flash-plugin: multiple code execution issues fixed in APSB17-33
Summary: CVE-2017-11213 CVE-2017-11215 CVE-2017-11225 CVE-2017-3112 CVE-2017-3114 flas...
Keywords:
Status: CLOSED ERRATA
Alias: CVE-2017-11213, CVE-2017-11215, CVE-2017-11225, CVE-2017-3112, CVE-2017-3114
Product: Security Response
Classification: Other
Component: vulnerability
Version: unspecified
Hardware: All
OS: Linux
urgent
urgent
Target Milestone: ---
Assignee: Red Hat Product Security
QA Contact:
URL:
Whiteboard: impact=critical,public=20171114,repor...
Depends On: 1513133 1513134
Blocks: 1513138
TreeView+ depends on / blocked
 
Reported: 2017-11-14 19:39 UTC by Tomas Hoger
Modified: 2019-06-08 22:29 UTC (History)
1 user (show)

Fixed In Version: flash-plugin 27.0.0.187
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-11-15 10:40:30 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHSA-2017:3222 normal SHIPPED_LIVE Critical: flash-plugin security update 2017-11-15 15:35:20 UTC

Description Tomas Hoger 2017-11-14 19:39:34 UTC
Adobe Security Bulletin APSB17-33 for Adobe Flash Player describes multiple flaws that can possibly lead to code execution when Flash Player is used to play a specially crafted SWF file.

Quoting from the APSB17-33:

Out-of-bounds Read 	Remote Code Execution 	Critical 	CVE-2017-3112
Out-of-bounds Read 	Remote Code Execution 	Critical 	CVE-2017-3114
Out-of-bounds Read 	Remote Code Execution 	Critical 	CVE-2017-11213
Use after free 		Remote Code Execution 	Critical 	CVE-2017-11215
Use after free 		Remote Code Execution 	Critical 	CVE-2017-11225

External References:

https://helpx.adobe.com/security/products/flash-player/apsb17-33.html

Comment 2 errata-xmlrpc 2017-11-15 10:35:48 UTC
This issue has been addressed in the following products:

  Red Hat Enterprise Linux 6 Supplementary

Via RHSA-2017:3222 https://access.redhat.com/errata/RHSA-2017:3222


Note You need to log in before you can comment on or make changes to this bug.